1#!/usr/bin/make -f
2# -*- mode: makefile; coding: utf-8 -*-
3# Copyright �� 2003 Jeff Bailey <jbailey@debian.org>
4#
5# This program is free software; you can redistribute it and/or
6# modify it under the terms of the GNU General Public License as
7# published by the Free Software Foundation; either version 2, or (at
8# your option) any later version.
9#
10# This program is distributed in the hope that it will be useful, but
11# WITHOUT ANY WARRANTY; without even the implied warranty of
12# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
13# General Public License for more details.
14#
15# You should have received a copy of the GNU General Public License
16# along with this program; if not, write to the Free Software
17# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
18# 02111-1307 USA.
19
20DEB_DH_INSTALLINIT_ARGS := '--no-start'
21#DEB_DH_LINK_ARGS := ../init.d/hdparm /etc/rcS.d/S07hdparm.first
22DEB_UPDATE_RCD_PARAMS := 'start 07 S . '
23DEB_FIXPERMS_EXCLUDE:= 20hdparm
24
25include /usr/share/cdbs/1/rules/dpatch.mk
26include /usr/share/cdbs/1/rules/debhelper.mk
27include /usr/share/cdbs/1/class/makefile.mk
28
29DEB_MAKE_INSTALL_TARGET := install DESTDIR=$(CURDIR)/debian/tmp
30
31common-install-prehook-arch::
32	install -d $(CURDIR)/debian/tmp/sbin
33binary-predeb/hdparm::
34	chmod 755 $(CURDIR)/debian/hdparm/etc/apm/event.d/20hdparm
35