1%define pref /usr
2%define ver  2.8.12
3%define ver2 2.8
4%define rel  0
5
6Summary: The SciTech MGL port of the wxWindows library
7Name: wxMGL
8Version: %{ver}
9Release: %{rel}
10License: wxWindows Licence
11Group: System/Libraries
12Source: wxMGL-%{ver}.tar.bz2
13URL: http://www.wxwindows.org
14Packager: Vaclav Slavik <vaclav@wxwindows.org>
15Prefix: %{pref}
16BuildRoot: /var/tmp/%{name}-root
17
18# all packages providing an implementation of wxWindows library (regardless of
19# the toolkit used) should provide the (virtual) wxwin package, this makes it
20# possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
21Provides: wxwin
22
23Provides: libwx_mgl.so
24Provides: libwx_mgl-%{ver2}.so
25
26Requires: mgl
27BuildRequires: mgl-devel
28
29%description
30wxWindows is a free C++ library for cross-platform GUI development.
31With wxWindows, you can create applications for different GUIs (GTK+,
32Motif/LessTif, MS Windows, Mac) from the same source code.
33
34%package devel
35Summary: The SciTech MGL port of the wxWindows library
36Group: Development/Libraries
37Requires: wxMGL = %{ver}
38
39%description devel
40Header files for wxMGL, the SciTech MGL port of the wxWindows library.
41
42%package static
43Summary: wxMGL static libraries
44Group: Development/Libraries
45
46%description static
47Static libraries for wxMGL. You need them if you want to link statically against wxMGL.
48
49%prep
50%setup -n wxMGL-%{ver}
51
52%build
53if [ "$SMP" != "" ]; then
54  export MAKE="make -j$SMP"
55else
56  export MAKE="make"
57fi
58
59mkdir obj-shared
60cd obj-shared
61../configure --prefix=%{pref} --with-mgl --disable-fs_inet
62$MAKE
63cd ..
64
65mkdir obj-static
66cd obj-static
67../configure --prefix=%{pref} --disable-shared --with-mgl --disable-fs_inet
68$MAKE
69cd ..
70
71%install
72rm -rf $RPM_BUILD_ROOT
73(cd obj-static; make prefix=$RPM_BUILD_ROOT%{pref} install)
74(cd obj-shared; make prefix=$RPM_BUILD_ROOT%{pref} install)
75
76%find_lang wxstd
77
78%clean
79rm -rf $RPM_BUILD_ROOT
80
81%post
82/sbin/ldconfig
83
84%postun
85/sbin/ldconfig
86
87%files -f wxstd.lang
88%defattr(-,root,root)
89%doc COPYING.LIB *.txt
90%{_libdir}/libwx_mgl*-%{ver2}*.so.*
91
92%files devel
93%defattr(-,root,root)
94%{_libdir}/libwx_mgl*-%{ver2}*.so
95%dir %{_includedir}/wx-*
96%{_includedir}/wx-*/*
97%dir %{_libdir}/wx
98%{_libdir}/wx/*
99%{_bindir}/wxmgl*-config
100%{_datadir}/aclocal/*.m4
101
102%files static
103%defattr (-,root,root)
104%{_libdir}/lib*.a
105