1%define _prefix /usr
2%define ver  2.8.12
3%define ver2 2.8
4%define rel  0
5
6# Configurable settings (use --with(out) {unicode,gtk2} on rpmbuild cmd line):
7%define unicode 1
8%{?_with_unicode: %{expand: %%define unicode 1}}
9%{?_without_unicode: %{expand: %%define unicode 0}}
10
11%define gtk2 1
12%{?_with_gtk2: %{expand: %%define gtk2 1}}
13%{?_without_gtk2: %{expand: %%define gtk2 0}}
14
15# "buildname" needs to be e.g. gtk2ud for debug builds
16%if %{gtk2}
17    %define gtkver 2
18    %define portname gtk2
19%if %{unicode}
20    %define buildname gtk2u
21%else
22    %define buildname gtk2
23%endif
24%else
25    %define gtkver 1.2
26    %define portname gtk
27    %define buildname gtk
28%endif
29
30%if %{unicode}
31    %define name		wx-%{portname}-unicode
32    %define wxconfig		%{portname}-unicode-release-%{ver2}
33    %define wxconfigstatic	%{portname}-unicode-release-static-%{ver2}
34    %define wxconfiglink	wx%{portname}u-%{ver2}-config
35%else
36    %define name		wx-%{portname}-ansi
37    %define wxconfig		%{portname}-ansi-release-%{ver2}
38    %define wxconfigstatic	%{portname}-ansi-release-static-%{ver2}
39    %define wxconfiglink	wx%{portname}-%{ver2}-config
40%endif
41
42%if %{unicode}
43    %define wxbasename		wx-base-unicode
44    %define wxbaseconfig	base-unicode-release-%{ver2}
45    %define wxbaseconfiglink	wxbaseu-%{ver2}-config
46%else
47    %define wxbasename		wx-base-ansi
48    %define wxbaseconfig	base-ansi-release-%{ver2}
49    %define wxbaseconfiglink	wxbase-%{ver2}-config
50%endif
51
52Summary: The GTK+ %{gtkver} port of the wxWidgets library
53Name: %{name}
54Version: %{ver}
55Release: %{rel}
56License: wxWindows Licence
57Group: X11/Libraries
58Source: wxGTK-%{ver}.tar.bz2
59URL: http://www.wxwidgets.org
60Packager: Vadim Zeitlin <vadim@wxwindows.org>
61Prefix: %{_prefix}
62BuildRoot: %{_tmppath}/%{name}-root
63Requires: %{wxbasename} = %{ver}
64%if %{portname} == gtk2
65BuildRequires: gtk+-2.0-devel
66%else
67BuildRequires: gtk+-devel >= 1.2.0
68%endif
69
70BuildRequires: zlib-devel, libjpeg-devel, libpng-devel, libtiff-devel
71
72# all packages providing an implementation of wxWidgets library (regardless of
73# the toolkit used) should provide the (virtual) wxwin package, this makes it
74# possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
75Provides: wxwin
76Provides: wxGTK
77
78%description
79wxWidgets is a free C++ library for cross-platform GUI development.
80With wxWidgets, you can create applications for different GUIs (GTK+,
81Motif, MS Windows, MacOS X, Windows CE, GPE) from the same source code.
82
83%package -n wx-i18n
84Summary: The translations for the wxWidgets library.
85Group: X11/Libraries
86
87%description -n wx-i18n
88The translations files for the wxWidgets library.
89
90%package devel
91Summary: The GTK+ %{gtkver} port of the wxWidgets library
92Group: X11/Libraries
93Requires: %{name} = %{ver}
94Requires: %{wxbasename}-devel = %{ver}
95Provides: wxGTK-devel
96
97%description devel
98The GTK+ %{gtkver} port of the wxWidgets library, header files.
99
100%package gl
101Summary: The GTK+ %{gtkver} port of the wxWidgets library, OpenGL add-on.
102Group: X11/Libraries
103Requires: %{name} = %{ver}
104Provides: wxGTK-gl
105
106%description gl
107OpenGL add-on library for wxGTK, the GTK+ %{gtkver} port of the wxWidgets library.
108
109%package -n %{wxbasename}
110Summary: wxBase library - non-GUI support classes of the wxWidgets toolkit
111Group: Development/Libraries
112Provides: wxBase
113
114%description -n %{wxbasename}
115wxBase is a collection of C++ classes providing basic data structures (strings,
116lists, arrays), portable wrappers around many OS-specific funstions (file
117operations, time/date manipulations, threads, processes, sockets, shared
118library loading) as well as other utility classes (streams, archive and
119compression). wxBase currently supports Win32, most Unix variants (Linux,
120FreeBSD, Solaris, HP-UX) and MacOS X (Carbon and Mach-0).
121
122%package -n %{wxbasename}-devel
123Summary: wxBase library, header files.
124Group: Development/Libraries
125Provides: wxBase-devel
126
127%description -n %{wxbasename}-devel
128wxBase library - non-GUI support classes of the wxWidgets toolkit,
129header files.
130
131%package contrib
132Summary: The GTK+ %{gtkver} port of the wxWidgets library, contributed libraries.
133Group: X11/Libraries
134Requires: %{name} = %{ver}
135
136%description contrib
137Contributed libraries for wxGTK, the GTK+ %{gtkver} port of the wxWidgets library.
138
139%package contrib-devel
140Summary: The GTK+ %{gtkver} port of the wxWidgets library
141Group: X11/Libraries
142Requires: %{name}-contrib = %{ver}
143Requires: %{name}-devel = %{ver}
144
145%description contrib-devel
146Header files for contributed libraries for wxGTK, the GTK+ %{gtkver} port of the wxWidgets library.
147
148%prep
149%setup -q -n wxGTK-%{ver}
150
151%build
152if [ "$SMP" != "" ]; then
153    export MAKE="make -j$SMP"
154else
155    export MAKE="make"
156fi
157
158mkdir obj-shared
159cd obj-shared
160../configure --prefix=%{_prefix} \
161%if ! %{gtk2}
162			      --with-gtk=1 \
163%else
164			      --with-gtk=2 \
165%endif
166%if %{unicode}
167			      --enable-unicode \
168%else
169			      --disable-unicode \
170			      --with-odbc \
171%endif
172			      --with-opengl
173$MAKE
174
175cd contrib/src
176$MAKE
177cd ../../..
178
179mkdir obj-static
180cd obj-static
181../configure --prefix=%{_prefix} \
182%if ! %{gtk2}
183			      --with-gtk=1 \
184%else
185			      --with-gtk=2 \
186%endif
187			      --disable-shared \
188%if %{unicode}
189			      --enable-unicode \
190%else
191			      --disable-unicode \
192			      --with-odbc \
193%endif
194			      --with-opengl
195$MAKE
196
197cd contrib/src
198$MAKE
199cd ../../..
200
201make -C locale allmo
202
203%install
204rm -rf $RPM_BUILD_ROOT
205(cd obj-static; make DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix} install)
206(cd obj-shared; make DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix} install)
207
208# --- wxBase headers list begins here ---
209cat <<EOF >wxbase-headers.files
210wx/afterstd.h
211wx/app.h
212wx/apptrait.h
213wx/archive.h
214wx/arrimpl.cpp
215wx/arrstr.h
216wx/beforestd.h
217wx/buffer.h
218wx/build.h
219wx/chkconf.h
220wx/clntdata.h
221wx/cmdline.h
222wx/confbase.h
223wx/config.h
224wx/convauto.h
225wx/containr.h
226wx/cpp.h
227wx/datetime.h
228wx/datstrm.h
229wx/dde.h
230wx/debug.h
231wx/defs.h
232wx/dir.h
233wx/dlimpexp.h
234wx/dynarray.h
235wx/dynlib.h
236wx/dynload.h
237wx/encconv.h
238wx/event.h
239wx/except.h
240wx/features.h
241wx/ffile.h
242wx/file.h
243wx/fileconf.h
244wx/filefn.h
245wx/filename.h
246wx/filesys.h
247wx/fontenc.h
248wx/fontmap.h
249wx/fs_arc.h
250wx/fs_filter.h
251wx/fs_mem.h
252wx/fs_zip.h
253wx/hash.h
254wx/hashmap.h
255wx/hashset.h
256wx/html/forcelnk.h
257wx/iconloc.h
258wx/init.h
259wx/intl.h
260wx/iosfwrap.h
261wx/ioswrap.h
262wx/ipc.h
263wx/ipcbase.h
264wx/isql.h
265wx/isqlext.h
266wx/link.h
267wx/list.h
268wx/listimpl.cpp
269wx/log.h
270wx/longlong.h
271wx/math.h
272wx/memconf.h
273wx/memory.h
274wx/memtext.h
275wx/mimetype.h
276wx/module.h
277wx/msgout.h
278wx/mstream.h
279wx/object.h
280wx/platform.h
281wx/platinfo.h
282wx/power.h
283wx/process.h
284wx/ptr_scpd.h
285wx/recguard.h
286wx/regex.h
287wx/scopeguard.h
288wx/snglinst.h
289wx/sstream.h
290wx/stack.h
291wx/stackwalk.h
292wx/stdpaths.h
293wx/stockitem.h
294wx/stopwatch.h
295wx/strconv.h
296wx/stream.h
297wx/string.h
298wx/sysopt.h
299wx/tarstrm.h
300wx/textbuf.h
301wx/textfile.h
302wx/thread.h
303wx/thrimpl.cpp
304wx/timer.h
305wx/tokenzr.h
306wx/txtstrm.h
307wx/types.h
308wx/uri.h
309wx/utils.h
310wx/variant.h
311wx/vector.h
312wx/version.h
313wx/volume.h
314wx/wfstream.h
315wx/wx.h
316wx/wxchar.h
317wx/wxprec.h
318wx/xti.h
319wx/xtistrm.h
320wx/zipstrm.h
321wx/zstream.h
322wx/unix/apptbase.h
323wx/unix/apptrait.h
324wx/unix/execute.h
325wx/unix/mimetype.h
326wx/unix/pipe.h
327wx/unix/private.h
328wx/unix/stackwalk.h
329wx/unix/stdpaths.h
330wx/fs_inet.h
331wx/gsocket.h
332wx/protocol/file.h
333wx/protocol/ftp.h
334wx/protocol/http.h
335wx/protocol/protocol.h
336wx/sckaddr.h
337wx/sckipc.h
338wx/sckstrm.h
339wx/socket.h
340wx/url.h
341wx/unix/gsockunx.h
342wx/xml/xml.h
343wx/xtixml.h
344wx/db.h
345wx/dbkeyg.h
346wx/dbtable.h
347EOF
348# --- wxBase headers list ends here ---
349cat <<EOF >wxbase-headers.paths
350%{_includedir}/wx-%{ver2}/wx/afterstd.h
351%{_includedir}/wx-%{ver2}/wx/app.h
352%{_includedir}/wx-%{ver2}/wx/apptrait.h
353%{_includedir}/wx-%{ver2}/wx/archive.h
354%{_includedir}/wx-%{ver2}/wx/arrimpl.cpp
355%{_includedir}/wx-%{ver2}/wx/arrstr.h
356%{_includedir}/wx-%{ver2}/wx/beforestd.h
357%{_includedir}/wx-%{ver2}/wx/buffer.h
358%{_includedir}/wx-%{ver2}/wx/build.h
359%{_includedir}/wx-%{ver2}/wx/chkconf.h
360%{_includedir}/wx-%{ver2}/wx/clntdata.h
361%{_includedir}/wx-%{ver2}/wx/cmdline.h
362%{_includedir}/wx-%{ver2}/wx/confbase.h
363%{_includedir}/wx-%{ver2}/wx/config.h
364%{_includedir}/wx-%{ver2}/wx/containr.h
365%{_includedir}/wx-%{ver2}/wx/convauto.h
366%{_includedir}/wx-%{ver2}/wx/datetime.h
367%{_includedir}/wx-%{ver2}/wx/datstrm.h
368%{_includedir}/wx-%{ver2}/wx/dde.h
369%{_includedir}/wx-%{ver2}/wx/debug.h
370%{_includedir}/wx-%{ver2}/wx/defs.h
371%{_includedir}/wx-%{ver2}/wx/dir.h
372%{_includedir}/wx-%{ver2}/wx/dlimpexp.h
373%{_includedir}/wx-%{ver2}/wx/dynarray.h
374%{_includedir}/wx-%{ver2}/wx/dynlib.h
375%{_includedir}/wx-%{ver2}/wx/dynload.h
376%{_includedir}/wx-%{ver2}/wx/encconv.h
377%{_includedir}/wx-%{ver2}/wx/event.h
378%{_includedir}/wx-%{ver2}/wx/except.h
379%{_includedir}/wx-%{ver2}/wx/features.h
380%{_includedir}/wx-%{ver2}/wx/ffile.h
381%{_includedir}/wx-%{ver2}/wx/file.h
382%{_includedir}/wx-%{ver2}/wx/fileconf.h
383%{_includedir}/wx-%{ver2}/wx/filefn.h
384%{_includedir}/wx-%{ver2}/wx/filename.h
385%{_includedir}/wx-%{ver2}/wx/filesys.h
386%{_includedir}/wx-%{ver2}/wx/fontenc.h
387%{_includedir}/wx-%{ver2}/wx/fontmap.h
388%{_includedir}/wx-%{ver2}/wx/fs_mem.h
389%{_includedir}/wx-%{ver2}/wx/fs_zip.h
390%{_includedir}/wx-%{ver2}/wx/hash.h
391%{_includedir}/wx-%{ver2}/wx/hashmap.h
392%{_includedir}/wx-%{ver2}/wx/hashset.h
393%{_includedir}/wx-%{ver2}/wx/html/forcelnk.h
394%{_includedir}/wx-%{ver2}/wx/iconloc.h
395%{_includedir}/wx-%{ver2}/wx/init.h
396%{_includedir}/wx-%{ver2}/wx/intl.h
397%{_includedir}/wx-%{ver2}/wx/iosfwrap.h
398%{_includedir}/wx-%{ver2}/wx/ioswrap.h
399%{_includedir}/wx-%{ver2}/wx/ipc.h
400%{_includedir}/wx-%{ver2}/wx/ipcbase.h
401%{_includedir}/wx-%{ver2}/wx/isql.h
402%{_includedir}/wx-%{ver2}/wx/isqlext.h
403%{_includedir}/wx-%{ver2}/wx/link.h
404%{_includedir}/wx-%{ver2}/wx/list.h
405%{_includedir}/wx-%{ver2}/wx/listimpl.cpp
406%{_includedir}/wx-%{ver2}/wx/log.h
407%{_includedir}/wx-%{ver2}/wx/longlong.h
408%{_includedir}/wx-%{ver2}/wx/math.h
409%{_includedir}/wx-%{ver2}/wx/memconf.h
410%{_includedir}/wx-%{ver2}/wx/memory.h
411%{_includedir}/wx-%{ver2}/wx/memtext.h
412%{_includedir}/wx-%{ver2}/wx/mimetype.h
413%{_includedir}/wx-%{ver2}/wx/module.h
414%{_includedir}/wx-%{ver2}/wx/msgout.h
415%{_includedir}/wx-%{ver2}/wx/mstream.h
416%{_includedir}/wx-%{ver2}/wx/object.h
417%{_includedir}/wx-%{ver2}/wx/platform.h
418%{_includedir}/wx-%{ver2}/wx/power.h
419%{_includedir}/wx-%{ver2}/wx/process.h
420%{_includedir}/wx-%{ver2}/wx/ptr_scpd.h
421%{_includedir}/wx-%{ver2}/wx/recguard.h
422%{_includedir}/wx-%{ver2}/wx/regex.h
423%{_includedir}/wx-%{ver2}/wx/scopeguard.h
424%{_includedir}/wx-%{ver2}/wx/snglinst.h
425%{_includedir}/wx-%{ver2}/wx/sstream.h
426%{_includedir}/wx-%{ver2}/wx/stack.h
427%{_includedir}/wx-%{ver2}/wx/stackwalk.h
428%{_includedir}/wx-%{ver2}/wx/stdpaths.h
429%{_includedir}/wx-%{ver2}/wx/stockitem.h
430%{_includedir}/wx-%{ver2}/wx/stopwatch.h
431%{_includedir}/wx-%{ver2}/wx/strconv.h
432%{_includedir}/wx-%{ver2}/wx/stream.h
433%{_includedir}/wx-%{ver2}/wx/string.h
434%{_includedir}/wx-%{ver2}/wx/sysopt.h
435%{_includedir}/wx-%{ver2}/wx/textbuf.h
436%{_includedir}/wx-%{ver2}/wx/textfile.h
437%{_includedir}/wx-%{ver2}/wx/thread.h
438%{_includedir}/wx-%{ver2}/wx/thrimpl.cpp
439%{_includedir}/wx-%{ver2}/wx/timer.h
440%{_includedir}/wx-%{ver2}/wx/tokenzr.h
441%{_includedir}/wx-%{ver2}/wx/txtstrm.h
442%{_includedir}/wx-%{ver2}/wx/types.h
443%{_includedir}/wx-%{ver2}/wx/uri.h
444%{_includedir}/wx-%{ver2}/wx/utils.h
445%{_includedir}/wx-%{ver2}/wx/variant.h
446%{_includedir}/wx-%{ver2}/wx/vector.h
447%{_includedir}/wx-%{ver2}/wx/version.h
448%{_includedir}/wx-%{ver2}/wx/volume.h
449%{_includedir}/wx-%{ver2}/wx/wfstream.h
450%{_includedir}/wx-%{ver2}/wx/wx.h
451%{_includedir}/wx-%{ver2}/wx/wxchar.h
452%{_includedir}/wx-%{ver2}/wx/wxprec.h
453%{_includedir}/wx-%{ver2}/wx/xti.h
454%{_includedir}/wx-%{ver2}/wx/xtistrm.h
455%{_includedir}/wx-%{ver2}/wx/zipstrm.h
456%{_includedir}/wx-%{ver2}/wx/zstream.h
457%{_includedir}/wx-%{ver2}/wx/fs_inet.h
458%{_includedir}/wx-%{ver2}/wx/gsocket.h
459%{_includedir}/wx-%{ver2}/wx/protocol/file.h
460%{_includedir}/wx-%{ver2}/wx/protocol/ftp.h
461%{_includedir}/wx-%{ver2}/wx/protocol/http.h
462%{_includedir}/wx-%{ver2}/wx/protocol/protocol.h
463%{_includedir}/wx-%{ver2}/wx/sckaddr.h
464%{_includedir}/wx-%{ver2}/wx/sckipc.h
465%{_includedir}/wx-%{ver2}/wx/sckstrm.h
466%{_includedir}/wx-%{ver2}/wx/socket.h
467%{_includedir}/wx-%{ver2}/wx/url.h
468%{_includedir}/wx-%{ver2}/wx/xml/xml.h
469%{_includedir}/wx-%{ver2}/wx/xtixml.h
470%{_includedir}/wx-%{ver2}/wx/db.h
471%{_includedir}/wx-%{ver2}/wx/dbkeyg.h
472%{_includedir}/wx-%{ver2}/wx/dbtable.h
473%{_includedir}/wx-%{ver2}/wx/unix/apptbase.h
474%{_includedir}/wx-%{ver2}/wx/unix/apptrait.h
475%{_includedir}/wx-%{ver2}/wx/unix/execute.h
476%{_includedir}/wx-%{ver2}/wx/unix/gsockunx.h
477%{_includedir}/wx-%{ver2}/wx/unix/mimetype.h
478%{_includedir}/wx-%{ver2}/wx/unix/pipe.h
479%{_includedir}/wx-%{ver2}/wx/unix/private.h
480%{_includedir}/wx-%{ver2}/wx/unix/stackwalk.h
481%{_includedir}/wx-%{ver2}/wx/unix/stdpaths.h
482EOF
483# --- wxBase headers list ends here ---
484
485# temporarily remove base headers
486mkdir $RPM_BUILD_ROOT/_save_dir
487cp -r $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2} $RPM_BUILD_ROOT/_save_dir
488for f in `cat wxbase-headers.files` ; do
489    rm -f $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2}/$f
490done
491# list of all core headers:
492find $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2} -type f | sed -e "s,$RPM_BUILD_ROOT,,g" >core-headers.files
493# move base headers (actually all headers) back again
494cp -f -r $RPM_BUILD_ROOT/_save_dir/* $RPM_BUILD_ROOT%{_includedir}
495rm -rf $RPM_BUILD_ROOT/_save_dir
496
497# contrib stuff:
498(cd obj-static/contrib; make DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix} install)
499(cd obj-shared/contrib; make DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix} install)
500
501# utils:
502(cd obj-shared/utils/wxrc; make DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix} install)
503
504# wx-config link is created during package installation, remove it for now
505rm -f $RPM_BUILD_ROOT%{_bindir}/wx-config
506
507%clean
508rm -rf $RPM_BUILD_ROOT
509
510%post
511/sbin/ldconfig
512
513%postun
514/sbin/ldconfig
515
516%post devel
517# link wx-config when you install RPM.
518%if %{unicode}
519    ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/wx-config
520%endif
521# link wx-config with explicit name.
522ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/%{wxconfiglink}
523/sbin/ldconfig
524
525%postun devel
526/sbin/ldconfig
527
528%preun devel
529%if %{unicode}
530    rm -f %{_bindir}/wx-config
531%endif
532rm -f %{_bindir}/%{wxconfiglink}
533
534%post -n %{wxbasename}
535/sbin/ldconfig
536
537%postun -n %{wxbasename}
538/sbin/ldconfig
539
540%post -n %{wxbasename}-devel
541# link wx-config with explicit name.
542ln -sf %{_libdir}/wx/config/%{wxbaseconfig} %{_bindir}/%{wxbaseconfiglink}
543/sbin/ldconfig
544
545%postun  -n %{wxbasename}-devel
546/sbin/ldconfig
547
548%preun  -n %{wxbasename}-devel
549rm -f %{_bindir}/%{wxbaseconfiglink}
550
551%post gl
552/sbin/ldconfig
553
554%postun gl
555/sbin/ldconfig
556
557%post contrib
558/sbin/ldconfig
559
560%postun contrib
561/sbin/ldconfig
562
563%post contrib-devel
564/sbin/ldconfig
565
566%postun contrib-devel
567/sbin/ldconfig
568
569%files
570%defattr(-,root,root)
571%doc COPYING.LIB *.txt
572%{_libdir}/libwx_%{buildname}_adv-%{ver2}.so.*
573%{_libdir}/libwx_%{buildname}_aui-%{ver2}.so.*
574%{_libdir}/libwx_%{buildname}_core-%{ver2}.so.*
575%if !%{unicode}
576    %{_libdir}/libwx_%{buildname}_dbgrid-%{ver2}.so.*
577%endif
578%{_libdir}/libwx_%{buildname}_html-%{ver2}.so.*
579%{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so.*
580%{_libdir}/libwx_%{buildname}_qa-%{ver2}.so.*
581%{_libdir}/libwx_%{buildname}_richtext-%{ver2}.so.*
582%{_libdir}/libwx_%{buildname}_xrc-%{ver2}.so.*
583
584%files -n wx-i18n
585%defattr(-,root,root)
586%{_datadir}/locale/*/LC_MESSAGES/*.mo
587
588%files devel -f core-headers.files
589%defattr(-,root,root)
590# shared libs
591%{_libdir}/libwx_%{buildname}_adv-%{ver2}.so
592%{_libdir}/libwx_%{buildname}_aui-%{ver2}.so
593%{_libdir}/libwx_%{buildname}_core-%{ver2}.so
594%if !%{unicode}
595    %{_libdir}/libwx_%{buildname}_dbgrid-%{ver2}.so
596%endif
597%{_libdir}/libwx_%{buildname}_gl-%{ver2}.so
598%{_libdir}/libwx_%{buildname}_html-%{ver2}.so
599%{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so
600%{_libdir}/libwx_%{buildname}_qa-%{ver2}.so
601%{_libdir}/libwx_%{buildname}_richtext-%{ver2}.so
602%{_libdir}/libwx_%{buildname}_xrc-%{ver2}.so
603# static libs
604%{_libdir}/libwx_%{buildname}_adv-%{ver2}.a
605%{_libdir}/libwx_%{buildname}_aui-%{ver2}.a
606%{_libdir}/libwx_%{buildname}_core-%{ver2}.a
607%if !%{unicode}
608    %{_libdir}/libwx_%{buildname}_dbgrid-%{ver2}.a
609%endif
610%{_libdir}/libwx_%{buildname}_gl-%{ver2}.a
611%{_libdir}/libwx_%{buildname}_html-%{ver2}.a
612%{_libdir}/libwx_%{buildname}_qa-%{ver2}.a
613%{_libdir}/libwx_%{buildname}_richtext-%{ver2}.a
614%{_libdir}/libwx_%{buildname}_xrc-%{ver2}.a
615%dir %{_libdir}/wx
616%{_libdir}/wx/config/%{wxconfig}
617%{_libdir}/wx/include/%{wxconfig}/wx/setup.h
618%{_libdir}/wx/config/%{wxconfigstatic}
619%{_libdir}/wx/include/%{wxconfigstatic}/wx/setup.h
620%{_bindir}/wxrc*
621
622%files -n %{wxbasename}
623%defattr(-,root,root)
624%{_libdir}/libwx_base*-%{ver2}.so.*
625
626%files -n %{wxbasename}-devel -f wxbase-headers.paths
627%defattr (-,root,root)
628%dir %{_includedir}/wx-%{ver2}
629%{_libdir}/libwx_base*-%{ver2}.so
630%{_libdir}/libwx_base*-%{ver2}.a
631%if %{unicode}
632    %{_libdir}/libwxregexu-%{ver2}.a
633%endif
634%dir %{_libdir}/wx
635%{_datadir}/aclocal/*.m4
636%{_datadir}/bakefile/presets/*
637
638%files gl
639%defattr(-,root,root)
640%{_libdir}/libwx_%{buildname}_gl-%{ver2}.so.*
641
642%files contrib
643%defattr(-,root,root)
644%{_libdir}/libwx_%{buildname}_animate-%{ver2}.so.*
645%{_libdir}/libwx_%{buildname}_deprecated-%{ver2}.so.*
646%{_libdir}/libwx_%{buildname}_fl-%{ver2}.so.*
647%{_libdir}/libwx_%{buildname}_gizmos-%{ver2}.so.*
648%{_libdir}/libwx_%{buildname}_gizmos_xrc-%{ver2}.so.*
649%{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so.*
650%{_libdir}/libwx_%{buildname}_ogl-%{ver2}.so.*
651%{_libdir}/libwx_%{buildname}_plot-%{ver2}.so.*
652%{_libdir}/libwx_%{buildname}_stc-%{ver2}.so.*
653%{_libdir}/libwx_%{buildname}_svg-%{ver2}.so.*
654
655# static libs
656%{_libdir}/libwx_%{buildname}_animate-%{ver2}.a
657%{_libdir}/libwx_%{buildname}_deprecated-%{ver2}.a
658%{_libdir}/libwx_%{buildname}_fl-%{ver2}.a
659%{_libdir}/libwx_%{buildname}_gizmos-%{ver2}.a
660%{_libdir}/libwx_%{buildname}_gizmos_xrc-%{ver2}.a
661%{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.a
662%{_libdir}/libwx_%{buildname}_ogl-%{ver2}.a
663%{_libdir}/libwx_%{buildname}_plot-%{ver2}.a
664%{_libdir}/libwx_%{buildname}_stc-%{ver2}.a
665%{_libdir}/libwx_%{buildname}_svg-%{ver2}.a
666
667%files contrib-devel
668%defattr(-,root,root)
669%dir %{_includedir}/wx-%{ver2}/wx/animate
670%{_includedir}/wx-%{ver2}/wx/animate/*
671%{_libdir}/libwx_%{buildname}_animate-%{ver2}.so
672
673%dir %{_includedir}/wx-%{ver2}/wx/deprecated
674%{_includedir}/wx-%{ver2}/wx/deprecated/*
675%{_libdir}/libwx_%{buildname}_deprecated-%{ver2}.so
676
677%dir %{_includedir}/wx-%{ver2}/wx/fl
678%{_includedir}/wx-%{ver2}/wx/fl/*
679%{_libdir}/libwx_%{buildname}_fl-%{ver2}.so
680
681%dir %{_includedir}/wx-%{ver2}/wx/gizmos
682%{_includedir}/wx-%{ver2}/wx/gizmos/*
683%{_libdir}/libwx_%{buildname}_gizmos-%{ver2}.so
684%{_libdir}/libwx_%{buildname}_gizmos_xrc-%{ver2}.so
685
686%dir %{_includedir}/wx-%{ver2}/wx/mmedia
687%{_includedir}/wx-%{ver2}/wx/mmedia/*
688%{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so
689
690%dir %{_includedir}/wx-%{ver2}/wx/ogl
691%{_includedir}/wx-%{ver2}/wx/ogl/*
692%{_libdir}/libwx_%{buildname}_ogl-%{ver2}.so
693
694%dir %{_includedir}/wx-%{ver2}/wx/plot
695%{_includedir}/wx-%{ver2}/wx/plot/*
696%{_libdir}/libwx_%{buildname}_plot-%{ver2}.so
697
698%dir %{_includedir}/wx-%{ver2}/wx/stc
699%{_includedir}/wx-%{ver2}/wx/stc/*
700%{_libdir}/libwx_%{buildname}_stc-%{ver2}.so
701
702%dir %{_includedir}/wx-%{ver2}/wx/svg
703%{_includedir}/wx-%{ver2}/wx/svg/*
704%{_libdir}/libwx_%{buildname}_svg-%{ver2}.so
705