1# $LastChangedRevision: 1827 $, $LastChangedDate: 2010-01-16 16:21:36 -0800 (Sat, 16 Jan 2010) $
2Summary:        Library to create and read several different archive formats
3Summary(pl):    Biblioteka do tworzenia i odczytu r�nych format�w archiw�w
4Name:           libarchive
5Version:        2.0a3
6Release:        1
7License:        BSD
8Group:          Libraries
9Source0: http://people.freebsd.org/~kientzle/libarchive/src/%{name}-%{version}.tar.gz
10Patch:          %{name}-0123457890.patch
11URL:            http://people.freebsd.org/~kientzle/libarchive/
12Requires:       glibc
13Requires:       zlib
14Requires:       bzip2
15BuildRequires:  gcc
16BuildRequires:  gcc-c++
17BuildRequires:  gawk
18BuildRequires:  zlib-devel
19BuildRequires:  bzip2
20BuildRoot:      %{_tmppath}/%{name}-%{version}-build
21
22%description
23Libarchive is a programming library that can create and read several
24different streaming archive formats, including most popular TAR
25variants and several CPIO formats. It can also write SHAR archives.
26
27%description -l pl
28Libarchive jest bibliotek� s�u�acto tworzenia i odczytu wielu
29r�nych strumieniowych format�w archiw�w, w��czaj�c w to popularne
30odmiany TAR oraz wiele format�w CPIO. Biblioteka ta potrafi tak�e
31zapisywaarchiwa SHAR.
32
33%package devel
34Summary:        Header files for libarchive library
35Summary(pl):    Pliki nag��wkowe biblioteki libarchive
36Group:          Development/Libraries
37Requires:       %{name} = %{version}-%{release}
38
39%description devel
40Header files for libarchive library.
41
42%description devel -l pl
43Pliki nag��wkowe biblioteki libarchive.
44
45%package static
46Summary:        Static libarchive library
47Summary(pl):    Statyczna biblioteka libarchive
48Group:          Development/Libraries
49Requires:       %{name}-devel = %{version}-%{release}
50
51%description static
52Static libarchive library.
53
54%description static -l pl
55Statyczna biblioteka libarchive.
56
57%package -n bsdtar
58Summary:        bsdtar - tar(1) implementation based on libarchive
59Summary(pl):    bsdtar - implementacja programu tar(1) oparta na libarchive
60Group:          Applications/Archiving
61Requires:       %{name} = %{version}-%{release}
62
63%description -n bsdtar
64bsdtar - tar(1) implementation based on libarchive.
65
66%description -n bsdtar -l pl
67bsdtar - implementacja programu tar(1), oparta na libarchive.
68
69%prep
70%setup -q
71%patch0 -p1
72
73%build
74mkdir -p %{buildroot}
75./configure \
76--prefix=%{_prefix} \
77--libexecdir=%{_libexecdir} \
78--mandir=%{_mandir} \
79--infodir=%{_infodir} \
80--enable-shared=yes \
81--enable-static=yes \
82| tee %{buildroot}/config.log
83make | tee %{buildroot}/make.log
84
85%install
86[ "%buildroot" != "/" ] && [ -d %buildroot ] && rm -rf %buildroot;
87make DESTDIR=%buildroot install
88# original install builds, but does install bsdtar
89cp .libs/%{name}.a %{buildroot}%{_libdir}
90cp bsdtar %{buildroot}%{_bindir}
91cp tar/bsdtar.1 %{buildroot}%{_mandir}/man1
92
93%clean
94rm -fr %buildroot
95
96%files
97%defattr(644,root,root,755)
98%{_libdir}/libarchive.a
99
100%files devel
101%defattr(644,root,root,755)
102%{_libdir}/libarchive.la
103%{_includedir}/*.h
104%doc %{_mandir}/man3/*
105%doc %{_mandir}/man5/*
106
107%files -n bsdtar
108%defattr(644,root,root,755)
109%attr(755,root,root) %{_bindir}/bsdtar
110%doc %{_mandir}/man1/bsdtar.1*
111
112%define date    %(echo `LC_ALL="C" date +"%a %b %d %Y"`)
113%changelog
114* %{date} PLD Team <feedback@pld-linux.org>
115All persons listed below can be reached at <cvs_login>@pld-linux.org
116
117$Log: libarchive.spec,v $
118Release 1  2006/12/12 rm1023@dcx.com
119- added libarchive-0123457890.patch for "0123457890" error
120- replaced libarchive-1.3.1.tar.gz with libarchive-2.0a3.tar.gz
121- removed obsolete -CVE-2006-5680.patch and -man_progname.patch
122
123Revision 1.6  2006/11/15 10:41:28  qboosh
124- BR: acl-devel,attr-devel
125- devel deps
126
127Revision 1.5  2006/11/08 22:22:25  twittner
128- up to 1.3.1
129- added BR: e2fsprogs-devel
130- added -CVE-2006-5680.patch agains entering in infinite
131loop in corrupt archives
132- added bsdtar package (bsdtar is included now in libarchive
133sources)
134- rel. 0.1 for testing
135
136Revision 1.4  2005/12/15 18:26:36  twittner
137- up to 1.2.37
138- removed -shared.patch (no longer needed)
139
140Revision 1.3  2005/10/05 17:00:12  arekm
141- up to 1.02.034
142
143Revision 1.2  2005/07/27 20:17:21  qboosh
144- typo
145
146Revision 1.1  2005/07/27 08:36:03  adamg
147- new
148