1#!/usr/bin/make -f
2#-*- makefile -*-
3# Made with the aid of dh_make, by Craig Small
4# Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
5# Some lines taken from debmake, by Christoph Lameter.
6
7# Uncomment this to turn on verbose mode.
8#export DH_VERBOSE=1
9export DH_COMPAT=3
10
11PACKAGE=$(shell dh_listpackages)
12
13ifndef PERL
14PERL = /usr/bin/perl
15endif
16
17ifndef DESTDIR
18DESTDIR=..
19endif
20TMP     =`pwd`/debian/$(PACKAGE)
21
22build: build-stamp
23build-stamp:
24	dh_testdir
25
26	
27	# Add here commands to compile the package.
28	$(PERL) Makefile.PL INSTALLDIRS=vendor
29	$(MAKE) OPTIMIZE="-O2 -g -Wall"
30
31	touch build-stamp
32
33clean:
34	dh_testdir
35	dh_testroot
36	rm -f build-stamp
37
38	# Add here commands to clean up after the build process.
39	-$(MAKE) realclean
40
41	dh_clean
42
43install: 
44	dh_testdir
45	dh_testroot
46	dh_clean -k
47	dh_installdirs
48
49	# Add here commands to install the package into debian/tmp.
50	#$(MAKE) install DESTDIR=`pwd`/debian/tmp
51	$(MAKE) install PREFIX=$(TMP)/usr
52
53
54# Build architecture-dependent files here.
55binary-arch: build install
56# We have nothing to do by default.
57
58# Build architecture-independent files here.
59binary-indep: build install
60#	dh_testversion
61	dh_testdir
62	dh_testroot
63	dh_installdocs BUGS TODO README examples/README docs/README
64	dh_installexamples
65	dh_installmenu
66#	dh_installemacsen
67#	dh_installinit
68	dh_installcron
69	dh_installman
70#	dh_undocumented
71	dh_installchangelogs CHANGES
72	dh_link
73	dh_strip
74	dh_compress
75	dh_fixperms
76#	dh_makeshlibs
77	dh_installdeb
78	dh_perl 
79	dh_shlibdeps
80	dh_gencontrol
81	dh_md5sums
82	dh_builddeb --destdir=$(DESTDIR)
83
84source diff:                                                                  
85	@echo >&2 'source and diff are obsolete - use dpkg-source -b'; false
86
87binary: binary-indep binary-arch
88.PHONY: build clean binary-indep binary-arch binary
89