1Summary: SASL API implementation
2Name: sasl
3Version: 2.0.1
4Release: 1
5Copyright: CMU
6Group: Libraries
7Source: ftp.andrew.cmu.edu:/pub/cyrus-mail/cyrus-sasl-2.0.1-ALPHA.tar.gz
8Packager: Rob Earhart <earhart@cmu.edu>
9Requires: gdbm
10
11%description
12This is an implemention of the SASL API, useful for adding
13authentication, authorization, and security to network protocols.  The
14SASL protocol itself is documented in rfc2222; the API standard is a
15work in progress.
16
17%package devel
18%summary: SASL development headers and examples
19
20%description devel
21This includes the header files and documentation needed to develop
22applications which use SASL.
23
24%package plug-anonymous
25%summary: SASL ANONYMOUS mechanism plugin
26
27%description plug-anonymous
28This plugin implements the SASL ANONYMOUS mechanism,
29used for anonymous authentication.
30
31%package plug-crammd5
32%summary: SASL CRAM-MD5 mechanism plugin
33
34%description plug-crammd5
35This plugin implements the SASL CRAM-MD5 mechanism.
36CRAM-MD5 is the mandatory-to-implement authentication mechanism for a
37number of protocols; it uses MD5 with a challenge/response system to
38authenticate the user.
39
40%package plug-digestmd5
41%summary: SASL DIGEST-MD5 mechanism plugin
42
43%description plug-digestmd5
44This plugin implements the latest draft of the SASL DIGEST-MD5
45mechanism.  Although not yet finalized, this is likely to become the
46new mandatory-to-implement authentication system in all new protocols.
47It's based on the digest md5 authentication system designed for HTTP.
48
49%package plug-kerberos4
50%summary: SASL KERBEROS_V4 mechanism plugin
51
52%description plug-kerberos4
53This plugin implements the SASL KERBEROS_V4 mechanism, allowing
54authentication via kerberos version four.
55
56%package plug-plain
57%summary: SASL PLAIN mechanism plugin
58
59%description plug-plain
60This plugin implements the SASL PLAIN mechanism.  Although insecure,
61PLAIN is useful for transitioning to new security mechanisms, as this
62is the only mechanism which gives the server a copy of the user's
63password.
64
65%package plug-scrammd5
66%summary: SASL SCRAM-MD5 mechanism plugin
67
68%description plug-scrammd5
69This plugin implements the SASL SCRAM-MD5 mechanism.  Although
70deprecated (this will be replaced by DIGEST-MD5 at some point), it may
71be useful for the time being.
72
73%prep
74%setup
75
76%build
77./configure --prefix=/usr --disable-java
78make
79
80%install
81make install
82
83%post
84if test $RPM_INSTALL_PREFIX/lib/sasl != /usr/lib/sasl; then
85  ln -s $RPM_INSTALL_PREFIX/lib/sasl /usr/lib/sasl
86fi
87
88%postun
89if test -L /usr/lib/sasl; then
90  rm /usr/lib/sasl
91fi
92
93%files
94%doc README COPYING ChangeLog NEWS AUTHORS
95/usr/lib/libsasl.so.5.0.0
96/usr/sbin/saslpasswd
97/usr/man/man8/saslpasswd.8
98
99%files devel
100%doc doc/rfc2222.txt sample/sample-client.c sample/sample-server.c testing.txt
101/usr/lib/libsasl.la
102/usr/include/sasl.h
103/usr/include/saslplug.h
104/usr/include/saslutil.h
105/usr/include/md5global.h
106/usr/include/md5.h
107/usr/include/hmac-md5.h
108
109%files plug-anonymous
110%doc doc/draft-newman-sasl-anon-00.txt
111/usr/lib/sasl/libanonymous.so.1.0.2
112/usr/lib/sasl/libanonymous.so
113
114%files plug-crammd5
115%doc doc/rfc1321.txt doc/rfc2095.txt doc/rfc2104.txt
116/usr/lib/sasl/libcrammd5.so.1.0.1
117/usr/lib/sasl/libcrammd5.so
118
119%files plug-digestmd5
120%doc doc/draft-leach-digest-sasl-01.txt 
121/usr/lib/sasl/libdigestmd5.so.0.0.1
122/usr/lib/sasl/libdigestmd5.so
123
124%files plug-kerberos4
125/usr/lib/sasl/libkerberos4.so.1.0.2
126/usr/lib/sasl/libkerberos4.so
127
128%files plug-plain
129/usr/lib/sasl/libplain.so.1.0.1
130/usr/lib/sasl/libplain.so
131