1#!/usr/bin/make -f
2# SPDX-License-Identifier: GPL-2.0-only
3
4# in case debian/rules is executed directly
5export DEB_RULES_REQUIRES_ROOT := no
6
7include debian/rules.vars
8
9ifneq (,$(filter-out parallel=1,$(filter parallel=%,$(DEB_BUILD_OPTIONS))))
10    NUMJOBS = $(patsubst parallel=%,%,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
11    MAKEFLAGS += -j$(NUMJOBS)
12endif
13
14# When KBUILD_VERBOSE is undefined (presumably you are directly working with
15# the debianized tree), show verbose logs unless DEB_BUILD_OPTION=terse is set.
16ifeq ($(origin KBUILD_VERBOSE),undefined)
17    ifeq (,$(filter terse,$(DEB_BUILD_OPTIONS)))
18        export KBUILD_VERBOSE := 1
19    else
20        Q := @
21    endif
22endif
23
24revision = $(lastword $(subst -, ,$(shell dpkg-parsechangelog -S Version)))
25CROSS_COMPILE ?= $(filter-out $(DEB_BUILD_GNU_TYPE)-, $(DEB_HOST_GNU_TYPE)-)
26make-opts = ARCH=$(ARCH) KERNELRELEASE=$(KERNELRELEASE) KBUILD_BUILD_VERSION=$(revision) $(addprefix CROSS_COMPILE=,$(CROSS_COMPILE))
27
28binary-targets := $(addprefix binary-, image image-dbg headers libc-dev)
29
30all-packages = $(shell dh_listpackages)
31image-package = $(filter linux-image-% user-%, $(filter-out %-dbg, $(all-packages)))
32image-dbg-package = $(filter %-dbg, $(all-packages))
33libc-dev-package = $(filter linux-libc-dev, $(all-packages))
34headers-package = $(filter linux-headers-%, $(all-packages))
35
36mk-files = $(patsubst binary-%,debian/%.files,$1)
37package = $($(@:binary-%=%-package))
38
39# DH_OPTION is an environment variable common for all debhelper commands.
40# We could 'export' it, but here it is passed from the command line to clarify
41# which package is being processed in the build log.
42DH_OPTIONS = -p$(package)
43
44define binary
45	$(Q)dh_testdir $(DH_OPTIONS)
46	$(Q)dh_testroot $(DH_OPTIONS)
47	$(Q)dh_prep $(DH_OPTIONS)
48	$(Q)+$(MAKE) $(make-opts) run-command KBUILD_RUN_COMMAND='+$$(srctree)/scripts/package/builddeb $(package)'
49	$(Q)dh_installdocs $(DH_OPTIONS)
50	$(Q)dh_installchangelogs $(DH_OPTIONS)
51	$(Q)dh_compress $(DH_OPTIONS)
52	$(Q)dh_fixperms $(DH_OPTIONS)
53	$(Q)dh_gencontrol $(DH_OPTIONS) -- -f$(call mk-files,$@)
54	$(Q)dh_md5sums $(DH_OPTIONS)
55	$(Q)dh_builddeb $(DH_OPTIONS) -- $(addprefix -Z,$(KDEB_COMPRESS))
56endef
57
58.PHONY: $(binary-targets)
59$(binary-targets): build-arch
60	$(Q)truncate -s0 $(call mk-files,$@)
61	$(if $(package),$(binary))
62
63.PHONY: binary binary-indep binary-arch
64binary: binary-arch binary-indep
65binary-indep: build-indep
66binary-arch: $(binary-targets)
67	$(Q)cat $(call mk-files,$^) > debian/files
68
69.PHONY: build build-indep build-arch
70build: build-arch build-indep
71build-indep:
72build-arch:
73	$(Q)$(MAKE) $(make-opts) olddefconfig
74	$(Q)$(MAKE) $(make-opts) $(if $(filter um,$(ARCH)),,headers) all
75
76.PHONY: clean
77clean:
78	$(Q)dh_clean
79	$(Q)rm -rf debian/deb-env.vars* debian/*.files
80	$(Q)$(MAKE) ARCH=$(ARCH) clean
81
82# If DEB_HOST_ARCH is empty, it is likely that debian/rules was executed
83# directly. Run 'dpkg-architecture --print-set --print-format=make' to
84# generate a makefile construct that exports all DEB_* variables.
85ifndef DEB_HOST_ARCH
86include debian/deb-env.vars
87
88debian/deb-env.vars:
89	$(Q)dpkg-architecture -a$$(cat debian/arch) --print-set --print-format=make > $@.tmp
90	$(Q)mv $@.tmp $@
91endif
92