1#!/usr/bin/make -f
2# Sample debian/rules that uses debhelper.
3# GNU copyright 1997 to 1999 by Joey Hess.
4
5# Uncomment this to turn on verbose mode.
6#export DH_VERBOSE=1
7
8# This is the debhelper compatability version to use.
9export DH_COMPAT=4
10
11build: build-stamp
12build-stamp:
13	dh_testdir
14
15	
16	# Add here commands to compile the package.
17	./configure --prefix=`pwd`/debian/bonnie++/usr --mandir=`pwd`/debian/bonnie++/usr/share/man
18	$(MAKE)
19
20	touch build-stamp
21
22clean:
23	dh_testdir
24	dh_testroot
25	rm -f build-stamp
26
27	# Add here commands to clean up after the build process.
28	-$(MAKE) clean
29	rm -f config.*
30
31	dh_clean
32
33install: build
34	dh_testdir
35	dh_testroot
36	dh_clean -k
37	dh_installdirs
38
39	# Add here commands to install the package into debian/bonnie++.
40	$(MAKE) install-bin
41	ln -s bonnie++ debian/bonnie++/usr/sbin/bonnie
42
43	touch install-stamp
44
45# Build architecture-independent files here.
46binary-indep: build install
47# We have nothing to do by default.
48
49# Build architecture-dependent files here.
50binary-arch: build install
51#	dh_testversion
52	dh_testdir
53	dh_testroot
54#	dh_installdebconf	
55	dh_installdocs
56#	dh_installexamples
57#	dh_installmenu
58#	dh_installemacsen
59#	dh_installpam
60#	dh_installinit
61#	dh_installcron
62	dh_installman *.1 *.8
63#	dh_installinfo
64#	dh_undocumented
65	dh_installchangelogs 
66	dh_strip
67	dh_compress
68	dh_fixperms
69	# You may want to make some executables suid here.
70#	dh_suidregister
71#	dh_makeshlibs
72	dh_installdeb
73#	dh_perl
74	dh_shlibdeps
75	dh_gencontrol
76	dh_md5sums
77	dh_builddeb
78
79binary: binary-indep binary-arch
80.PHONY: build clean binary-indep binary-arch binary install
81