History log of /fuchsia/zircon/system/utest/thread-state/thread-state.cpp
Revision Date Author Comments
# d1867d4f 07-Sep-2018 George Kulakowski <kulakowski@google.com>

[compiler.h] Migrate many C++ clients of countof to fbl::count_of

The latter is safer in C++, and the former is a namespace violation in
compiler.h that eventually needs to be resolved.

Test: CQ; should be no functional change
Change-Id: I9809b9fe062fd5f07226323035bf094b3f9de798


# 4956d002 21-Aug-2018 Mark Seaborn <mseaborn@google.com>

[utest] Remove empty-string "msg" args from EXPECT/ASSERT calls in C++

The "msg" argument is optional in C++. A number of instances of
empty-string "msg" arguments have appeared since I last removed them.

This cleanup was automated.

Bug: ZX-905
Test: compile
Change-Id: Ia5ef96a2bc5a91dd8d1d62c90802c26f44f1a31f


# 53a24913 21-Jun-2018 Adam Barth <abarth@chromium.org>

[syscalls] Remove read_status from zx_channel_call

This parameter no longer has a purpose. Also, remove ZX_ERR_CALL_FAILED.
This status code no longer has a purpose.

Test: No behavior change
Change-Id: I71945ea9d1d6d591a20476106df1e598dfaf97b1


# bc7af9ec 11-Jun-2018 Adam Barth <abarth@chromium.org>

[zircon] Normal spelling of EVENTPAIR

Previously, we had EPAIR, EVPAIR, and EVENT_PAIR. Now we just use
EVENTPAIR, to match the "eventpair" noun in the syscalls.

Change-Id: Id5b3b33aca02921980022e3d69acae40aaab9eae


# dce0e872 11-Jun-2018 Adam Barth <abarth@google.com>

[musl] Rename zx_get_startup_handle to zx_take_startup_handle

The new name more clearly describes the ownership semantics.

ZX-2235 #comment

Change-Id: I887c1f2ad657e3aff9716b9f1865184cb8cf05f7


# 037a1570 24-Apr-2018 Doug Evans <dje@google.com>

[blocking syscalls] Record reason for being blocked

ZX-1843 #comment patch

Change-Id: I18ef3147cb91e87bb846ea9da4bdae1cdde5f98d