History log of /fuchsia/zircon/system/ulib/dispatcher-pool/dispatcher-timer.cpp
Revision Date Author Comments
# b33437b1 26-Jul-2018 Nick Maniscalco <maniscalco@google.com>

[zircon][kernel] Use proper time types and overflow-safe arithmetic

This change is preparation for converting zx_time_t and zx_duration_t
from unsigned to signed types (ZX-2100).

1. Fix several places where the wrong time type was used (e.g.
zx_time_t instead of zx_duration_t). Because these are simple typedefs
it's easy to use the wrong one. While it generally doesn't cause a
problem, using the wrong type can be misleading and lead to bugs like
passing a relative time when an absolute time is expected.

2. Update kernel/ and some other parts of zircon to use the new
overflow-safe arithmetic functions from zircon/time.h.

Performance: Ran "/pkgfs/packages/zircon_benchmarks/0/bin/app -p" on
NUC before and after this change. Differences were withing the noise,
some slightly faster, some slightly slower.

Test: CQ

ZX-2100 #comment cleanup before conversion

Change-Id: I75d074e5850ade5385decd9bbf330497bf7610e9


# 47cff597 26-Jun-2018 George Kulakowski <kulakowski@google.com>

[clock] zx_clock_get(ZX_CLOCK_MONOTONIC) -> zx_clock_get_monotonic()

Test: no functional change

Change-Id: Iaa513c521d96b178458acc707be3646067971701


# e0d70dec 16-Mar-2018 James Robinson <jamesr@google.com>

[zx] Move public zx headers to match naming convention

The zx library provides headers intended for general use, so the
include path should be spelled <lib/zx/foo.h> as per
https://fuchsia.googlesource.com/docs/+/master/development/languages/c-cpp/naming.md.
This moves the headers into the proper location and updates includes to
match.

Change-Id: I6fc9b2a491b5f8b0d270c4dfc77fa4be5739071b


# ec9928ea 22-Jan-2018 Adam Barth <abarth@google.com>

[syscalls] Rename zx_time_get to zx_clock_get

This change frees up the get() method in for a zx_time_t accessor in the
zx::time class.

Change-Id: Ia4cdc7e3e558df5ba0cfeedb27a442abf4d6f305


# a1c82ffb 15-Dec-2017 Jocelyn Dang <jocelyndang@google.com>

[ulib][dispatcher-pool] Remove dispatcher pool from audio namespace as
it will be used for video as well.

Change-Id: Ibfdf0711a1c291b8661ed1fb2d3ab8280b676c79


# 1c2e07f3 23-Oct-2017 Mike Voydanoff <voydanoff@google.com>

[ulib][dispatcher-pool] Build with zircon build system and fix header paths

Also fix error path that was broken due to missing brackets in "if" statement

Change-Id: Ib5816ef716acc2ac60a7f05760b20942b5998855


# 212c82fc 23-Oct-2017 Mike Voydanoff <voydanoff@google.com>

[dev][audio] Move //drivers/audio project to zircon

Change-Id: I5b60b0134a9d2d788922244b81401bc55d9837e8