History log of /fuchsia/zircon/system/ulib/audio-utils/audio-input.cpp
Revision Date Author Comments
# e302c45d 26-Jul-2018 Nick Maniscalco <maniscalco@google.com>

[zircon][syscalls] Make zx_time_t and zx_duration_t signed types

This change is part of a hard transition and breaks the layers above.

zx_time_t and zx_duration_t are now int64_t. ZX_TIME_INFINITE is now
INT64_MAX.

A negative time value passed to a syscall is treated as any other time
value that's "in the past".

Test: CQ; new unit tests; built and ran topaz system on Eve

ZX-2100 #comment

Change-Id: I2a020cb2cf3dd7212608e24c1ee90cec58dd51ef


# b33437b1 26-Jul-2018 Nick Maniscalco <maniscalco@google.com>

[zircon][kernel] Use proper time types and overflow-safe arithmetic

This change is preparation for converting zx_time_t and zx_duration_t
from unsigned to signed types (ZX-2100).

1. Fix several places where the wrong time type was used (e.g.
zx_time_t instead of zx_duration_t). Because these are simple typedefs
it's easy to use the wrong one. While it generally doesn't cause a
problem, using the wrong type can be misleading and lead to bugs like
passing a relative time when an absolute time is expected.

2. Update kernel/ and some other parts of zircon to use the new
overflow-safe arithmetic functions from zircon/time.h.

Performance: Ran "/pkgfs/packages/zircon_benchmarks/0/bin/app -p" on
NUC before and after this change. Differences were withing the noise,
some slightly faster, some slightly slower.

Test: CQ

ZX-2100 #comment cleanup before conversion

Change-Id: I75d074e5850ade5385decd9bbf330497bf7610e9


# 47cff597 26-Jun-2018 George Kulakowski <kulakowski@google.com>

[clock] zx_clock_get(ZX_CLOCK_MONOTONIC) -> zx_clock_get_monotonic()

Test: no functional change

Change-Id: Iaa513c521d96b178458acc707be3646067971701


# aa3b7734 24-Jan-2018 Adam Barth <abarth@google.com>

[zx] Update callers to zx::time and zx::duration types

The zx_time_t and zx_duration_t variants will be removed eventually.

Change-Id: Icc54983edc154eee2d1258160f921c3afc212ae0


# ec9928ea 22-Jan-2018 Adam Barth <abarth@google.com>

[syscalls] Rename zx_time_get to zx_clock_get

This change frees up the get() method in for a zx_time_t accessor in the
zx::time class.

Change-Id: Ia4cdc7e3e558df5ba0cfeedb27a442abf4d6f305


# 489cc076 14-Nov-2017 Mina Almasry <almasrymina@google.com>

[dev][gauss audio] Cache invalidate VMO before reading bytes

This is necessary on arm64 for the gauss audio input driver to work.

Bug: 68019773
Test: Record using audio test app
Change-Id: Iac545ef7875c3c967196d9b64c3c3c980ed53a98


# bd4900ab 07-Nov-2017 Mina Almasry <almasrymina@google.com>

Fix buffer size in audio app

According to audio.md:
"Clients must use the returned VMOs size (in bytes) to determine the actual
size of the ring buffer..."

The audio app uses the requested buffer size for some calculation after
getting the VMO. It should use the VMO size instead.

Bug: None
Test: With gauss driver
Change-Id: Id5f6d56678a8f3be14b67036c23a2e16fdf62e0e


# f3e2126c 12-Sep-2017 Roland McGrath <mcgrathr@google.com>

[zx] Magenta -> Zircon

The Great Renaming is here!

Change-Id: I3229bdeb2a3d0e40fb4db6fec8ca7d971fbffb94


# 59e644b1 07-Sep-2017 George Kulakowski <kulakowski@google.com>

[zircon][mxtl->fbl] Rename mxtl to fbl

Change-Id: Ie21b6498e1bfb0a7fa0315e40b9e5c3ee78646be


# b89c7ec4 31-Jul-2017 John Grossman <johngro@google.com>

[audio][utils] Fix a bug in the audio::utils::AudioInput

Don't use the requested ring buffer size when figuring out where the
ring wraps. Instead, pay attention to the actual size of the buffer
which the driver gives us. The driver is free to allocate a larger
buffer if needed in order to satisfy alignment and DMA requirements.

Change-Id: I0ec37ec78c3c5682047325b8163169af69f10ada


# 10a03ab6 03-Aug-2017 Jeff Brown <jeffbrown@google.com>

[mxtl][mxalloc] Redirect all clients of mxalloc to mxtl.

Change-Id: Ib6d88937212ab23612f59add8bd028862308ead5


# a997f5c4 18-Jul-2017 John Grossman <johngro@google.com>

[audio] Continue to phase out the old audio driver interface.

++ Duplicate the device/audio2.h protocol header file into
device/audio.h. Update all symbols to be audio* instead of
audio2*.
++ Duplicate the audio2-utils library, but have it refer to audio*
instead of audio2* everywhere.
++ Rename the audio2 test app to just audio. Make it use audio-utils
instead of audio2 utils.
++ Update the bcm-pcm audio driver to use device/audio.h and audio*
symbols.
++ Update the driver interface documentation to reflect that the name
transition from audio2 -> audio is now complete.

Change-Id: Ic1eaf301cd55072dd2ebb19b61447a37c02b6aad