History log of /fuchsia/zircon/kernel/object/pci_device_dispatcher.cpp
Revision Date Author Comments
# a42c1b60 11-Sep-2018 Roland McGrath <mcgrathr@google.com>

[kernel] WITH_DEV_PCIE -> WITH_KERNEL_PCIE

Hard-code this in KERNEL_DEFINES rather than relying on the
magic predefine based on the presence of the dev/pcie module.

Test: CQ & manual verification that kernel text size didn't change
Change-Id: Id827a8a93bc61ac8b1d7727f51a18f53277a7a16


# 36320886 19-Jul-2018 Corey Tabaka <eieio@google.com>

[kernel] Dispatchers and most kernel objects lockdep instrumented.

- Convert SoloDispatcher to a CRTP template type similar to
PeerDispatcher. This makes the lock classes for different solo
dispatchers distinct.
- Instrument the locks for all dispatchers.
- Instrument the locks for all kernel objects except those that
lock the thread_lock.

Bug: ZX-23
Test: k ut all and system/test/* pass + manual stress testing.

Change-Id: I8106c04911e47ea15ccce8e7abd5fbd62adfa6fe


# f3e2126c 12-Sep-2017 Roland McGrath <mcgrathr@google.com>

[zx] Magenta -> Zircon

The Great Renaming is here!

Change-Id: I3229bdeb2a3d0e40fb4db6fec8ca7d971fbffb94


# 59e644b1 07-Sep-2017 George Kulakowski <kulakowski@google.com>

[zircon][mxtl->fbl] Rename mxtl to fbl

Change-Id: Ie21b6498e1bfb0a7fa0315e40b9e5c3ee78646be


# 8779b382 01-Sep-2017 Dave Bort <dbort@google.com>

[user_copy] Remove lib/user_copy.h and object/user_copy.h

Make everyone use user_ptr or arch_copy_{to/from}_user.

Change-Id: I599463711fcd28f96638bae8dc6e59c106a11fd4


# 388a7f68 31-Aug-2017 Dave Bort <dbort@google.com>

[lib/magenta] Rename kernel/lib/magenta to kernel/object

TODO: Rename magenta.{cpp,h} and other instances of "magenta" in this
module.

For MG-1091 "Rename kernel/lib/magenta"

Change-Id: I2abc316f543798e00d3a4d1c2c83195da26e6836