History log of /freebsd-current/tools/regression/geom_gpt/gctl_test.t
Revision Date Author Comments
# d0b2dbfa 16-Aug-2023 Warner Losh <imp@FreeBSD.org>

Remove $FreeBSD$: one-line sh pattern

Remove /^\s*#[#!]?\s*\$FreeBSD\$.*$\n/


# 22184bfa 10-Jun-2017 Enji Cooper <ngie@FreeBSD.org>

Improve handling with system state

- Always unlink $cmd after exit via END block.
- The tests don't function well if kern.geom.debugflags != 0. Save debugflags,
then restore them at the end of the test.

MFC after: 1 month
Sponsored by: Dell EMC Isilon


# e15b2a78 10-Jun-2017 Enji Cooper <ngie@FreeBSD.org>

Don't explicitly get the class to PART in gctl_test_helper.c

This will allow the tool to be used with arbitrary geom(4) classes, like GEOM.

Specify class=PART explicitly in the tester to keep existing behavior.

MFC after: 1 month
Sponsored by: Dell EMC Isilon


# 67b1f73f 22-Apr-2017 Enji Cooper <ngie@FreeBSD.org>

gctl_test.t: catch errors with the mdcfg directive

While here, add a note about certain testcases relying on `count=1024` in
the "create" portion.

MFC after: 5 weeks
Sponsored by: Dell EMC Isilon


# d1f57d59 22-Apr-2017 Enji Cooper <ngie@FreeBSD.org>

gctl_test.t: improve error reporting with mdcfg and mount directives

If the commands had failed previously, it would press on and result in a
series of cascading failures. Fail early and continue on to the next case
instead of executing additional commands after a previously failed series
of steps.

MFC after: 5 weeks
Sponsored by: Dell EMC Isilon


# 9940eaaa 22-Apr-2017 Enji Cooper <ngie@FreeBSD.org>

gctl_test.t: more tweaks to try and update the code and get it functional (again?)

- Make the logfile for $out be built off the basename for $cmd, instead of $cmd.
(r317292 broke this assumption).
- Rename $mntpt to $mntpt_prefix for clarity, as this variable is a prefix for
mountpoints.
- Reindent the umount directive block while here to match the rest of the code.

MFC after: 5 weeks
Sponsored by: Dell EMC Isilon


# 414bf3a1 22-Apr-2017 Enji Cooper <ngie@FreeBSD.org>

Use verb=delete not verb=remove

The `remove` verb hasn't been present in geom_part*(4) for well
over a decade, if ever. I couldn't find any references to it in
^/stable/5 at least, which is around the timeframe that this test
was written.

MFC after: 5 weeks
Sponsored by: Dell EMC Isilon


# acca703a 22-Apr-2017 Enji Cooper <ngie@FreeBSD.org>

gctl_test.t: minor tweaks

- Declare $count with the `my` scope operator to permit `use strict`.
- Add `use strict`.
- Use `use warnings` instead of using `-w` in the shebang.
- Don't unlink $cmd when done (prevents unnecessary rebuilding).
- Improve the error message when running with insufficient permissions, e.g.,
non-root.

MFC after: 5 weeks
Sponsored by: Dell EMC Isilon


# b58910a0 22-Apr-2017 Enji Cooper <ngie@FreeBSD.org>

gctl_test.t: use make to compile gctl_test_helper instead of calling cc directly

MFC after: 5 weeks
Sponsored by: Dell EMC Isilon


# e02a067a 22-Apr-2017 Enji Cooper <ngie@FreeBSD.org>

Rename gctl.t to gctl_test.t and test.c to gctl_test_helper.c

This is being done to reduce ambiguity and to make the tests more portable
in the future to other locations in the source tree.

MFC after: 5 weeks
Sponsored by: Dell EMC Isilon