History log of /freebsd-current/sys/arm/altera/socfpga/socfpga_mp.c
Revision Date Author Comments
# fdafd315 24-Nov-2023 Warner Losh <imp@FreeBSD.org>

sys: Automated cleanup of cdefs and other formatting

Apply the following automated changes to try to eliminate
no-longer-needed sys/cdefs.h includes as well as now-empty
blank lines in a row.

Remove /^#if.*\n#endif.*\n#include\s+<sys/cdefs.h>.*\n/
Remove /\n+#include\s+<sys/cdefs.h>.*\n+#if.*\n#endif.*\n+/
Remove /\n+#if.*\n#endif.*\n+/
Remove /^#if.*\n#endif.*\n/
Remove /\n+#include\s+<sys/cdefs.h>\n#include\s+<sys/types.h>/
Remove /\n+#include\s+<sys/cdefs.h>\n#include\s+<sys/param.h>/
Remove /\n+#include\s+<sys/cdefs.h>\n#include\s+<sys/capsicum.h>/

Sponsored by: Netflix


# 685dc743 16-Aug-2023 Warner Losh <imp@FreeBSD.org>

sys: Remove $FreeBSD$: one-line .c pattern

Remove /^[\s*]*__FBSDID\("\$FreeBSD\$"\);?\s*\n/


# 6414b02d 28-Feb-2017 Ruslan Bukin <br@FreeBSD.org>

Add SOC_ALTERA_* kernel options per each SoC and use it to
conditionally compile the code.

Reviewed by: andrew
Sponsored by: DARPA, AFRL
Differential Revision: https://reviews.freebsd.org/D9836


# 42815783 28-Feb-2017 Ruslan Bukin <br@FreeBSD.org>

Add support for Intel Arria 10 SoC Development Kit.
Use standard DTS files for SOCKIT and SOCDK.

Sponsored by: DARPA, AFRL


# 5267f624 06-Feb-2017 Andrew Turner <andrew@FreeBSD.org>

Add support for PLATFORM and PLATFORM_SMP to the Altera SOCFPGA SoC. This
will help with moving it to GENERIC.

Reviewed by: br
Sponsored by: ABT Systems Ltd
Differential Revision: https://reviews.freebsd.org/D9461


# 7cc70732 06-Oct-2016 Michal Meloun <mmel@FreeBSD.org>

ARM: SEV/WFE instructions are implemented starting from ARMv6K,
use it directly.

MFC after: 1 week


# 7133fe0f 26-Feb-2016 Andrew Turner <andrew@FreeBSD.org>

Almost all copies of platform_mp_init_secondary just called
intr_pic_init_secondary. Replace them with a direct call. On BCM2836
and ARMADA XP we need to add this function, but it can be empty.

Reviewed by: ian, imp
Sponsored by: ABT Systems Ltd
Differential Revision: https://reviews.freebsd.org/D5460


# 3210b875 26-Feb-2016 Andrew Turner <andrew@FreeBSD.org>

Remove platform_mp_probe as it's almost identical on most ARM SoCs, and
slightly wrong on the others. We should just check if mp_ncpus is set to
more than one CPU as we may wish to run on a single core even when SMP is
available.

Reviewed by: ian
Sponsored by: ABT Systems Ltd
Differential Revision: https://reviews.freebsd.org/D5458


# 243b36c3 25-Feb-2016 Andrew Turner <andrew@FreeBSD.org>

Remove platform_ipi_send, it's an unneeded as all implementations are
identical.

Sponsored by: ABT Systems Ltd


# a89156f5 05-Feb-2016 Michal Meloun <mmel@FreeBSD.org>

ARM: Use new ARMv6 naming conventions for cache and TLB functions
in all but ARMv4 specific files.
Expand ARMv6 compatibility stubs in cpu-v4.h. Use physical address
in L2 cache functions if ARM_L2_PIPT is defined.


# 2b3ad188 17-Dec-2015 Adrian Chadd <adrian@FreeBSD.org>

[intrng] Migrate the intrng code from sys/arm/arm to sys/kern/subr_intr.c.

The ci20 port (by kan@) is going to reuse almost all of the intrng code
since the SoC in question looks suspiciously like someone took an ARM
SoC design and replaced the ARM core with a MIPS core.

* migrate out the code;
* rename ARM_ -> INTR_;
* rename arm_ -> intr_;
* move the interrupt flush routine from intr.c / intrng.c into
arm/machdep_intr.c - removing the code duplication and removing
the ARM specific bits from here.

Thanks to the Star Wars: The Force Awakens premiere line for allowing
me a couple hours of quiet time to finish the universe builds.

Tested:

* make universe

TODO:

* The structure definitions in subr_intr.c still includes machine/intr.h
which requires one duplicates all of the intrng definitions in
the platform code (which kan has done, and I think we don't have to.)

Instead I should break out the generic things (function declarations,
common intr structures, etc) into a separate header.

* Kan has requested I make the PIC based IPI stuff optional.


# 7ce00ee7 18-Oct-2015 Ian Lepore <ian@FreeBSD.org>

Rename arm_init_secondary_ic() -> arm_pic_init_secondary(). The latter is
the name the function will have when the new ARM_INTRNG code is integrated,
and doing this rename first will make it easier to toggle the new interrupt
handling code on/off with a config option for debugging.


# 087af50a 04-Apr-2015 Andrew Turner <andrew@FreeBSD.org>

Include vm/pmap.h for pmap_kextract.


# 3f53a2d6 11-Jan-2015 Andrew Turner <andrew@FreeBSD.org>

Rename gic_init_secondary to arm_init_secondary_ic to help with the merge
of the arm_intrng project branch.


# d4d630ae 10-Oct-2014 Ruslan Bukin <br@FreeBSD.org>

o Add machine-dependent SMP part
o Enable SMP

Sponsored by: DARPA, AFRL