History log of /barrelfish-master/include/barrelfish_kpi/types.h
Revision Date Author Comments
# 9bd8d1d5 03-Apr-2019 Reto Achermann <reto.achermann@inf.ethz.ch>

replacing umlaute and fixing address in headers Haldeneggsteig -> Universitaetsstrasse

Signed-off-by: Reto Achermann <reto.achermann@inf.ethz.ch>


# 2db902db 22-Dec-2017 Lukas Humbel <lukas.humbel@inf.ethz.ch>

kaluga: Make sure start_decnet doesnt break x86

Also refactor irq src cap management int int_caps.c/h

Signed-off-by: Lukas Humbel <lukas.humbel@inf.ethz.ch>


# ecf0b8e8 20-Aug-2017 Razvan Damachi <razvan.damachi@gmail.com>

Fix bug in libdomain/domain_cap_hash()

Signed-off-by: Razvan Damachi <razvan.damachi@gmail.com>


# d7244e94 21-Jun-2017 Adam Turowski <adam.turowski@inf.ethz.ch>

numa: changing PRI macros to SCN in a scanf-alike call

Signed-off-by: Adam Turowski <adam.turowski@inf.ethz.ch>


# a3521bd6 06-Mar-2017 Reto Achermann <reto.achermann@inf.ethz.ch>

making hwid_t to be uintptr_t

Signed-off-by: Reto Achermann <reto.achermann@inf.ethz.ch>


# 7a06d2b7 03-Mar-2017 Reto Achermann <reto.achermann@inf.ethz.ch>

Adding type for the core's hardware id hwid_t

Signed-off-by: Reto Achermann <reto.achermann@inf.ethz.ch>


# 05f3eb5a 27-Nov-2016 Adam Turowski <adam.turowski@inf.ethz.ch>

systime: introducing system time based on time stamp counter/global timer, removing kernel_now

Signed-off-by: Adam Turowski <adam.turowski@inf.ethz.ch>


# 69b41b96 18-Apr-2016 Simon Gerber <simon.gerber@inf.ethz.ch>

Squashed changes of e89aa91..6ca6bdf (master as of 2016-04-18).

Take this commit out when merging

Signed-off-by: Simon Gerber <simon.gerber@inf.ethz.ch>


# 587a3ca3 09-Mar-2016 Adam Turowski <adam.turowski@inf.ethz.ch>

Adding an option to warn about comparisions that are always true or false.

Signed-off-by: Adam Turowski <adam.turowski@inf.ethz.ch>


# b3c55525 08-Feb-2016 Moritz Hoffmann <moritz.hoffmann@inf.ethz.ch>

hamlet, kpi types, caps: add pasid type

The type represents a physical address space identifier. This patch adds support
in hamlet for a `pasid' type and declares the corresponding pasid_t and macros
in barrelfish_kpi/types.h. It changes caps.hl to use the new type instead of
uint32. The pasid type is represented by a uint32 at the moment.

Signed-off-by: Moritz Hoffmann <moritz.hoffmann@inf.ethz.ch>


# 4224169c 16-Dec-2014 Reto Achermann <reto.achermann@inf.ethz.ch>

libnuma: changes in type defs and macros

* moved definition of nodeid_t into types.h
* changed printf specifies to use PRIuNODEID
* changes in debug macros to take arguments
* additional sanity checks for core/node ids


# 49d9d284 22-Jun-2012 Raphael Fuchs <raphaelfuchs@student.ethz.ch>

Added ID capability, providing a system-wide unique ID.

The ID capability currently supports one invocation called 'identify', to
retrieve the system-wide unique ID.

The Domain capability, which was never used, is removed with this patch, since
the ID capability provides a more general capability.


# 7847b914 05-May-2012 Raphael Fuchs <raphaelfuchs@student.ethz.ch>

Fixed bug in resource id defines.


# cba58299 05-Feb-2012 Kornilios Kourtis <kkourt@inf.ethz.ch>

newlib,x86_32: use PRI{u,x}32, PRI{u,x}PTR, etc in format strings

Again this is needed because newlib defines uint32_t as unsigned long.
(In retrospect, I should just changed newlib's uint32_t to unsigned int)

Checkpoint:
compiles and boots qemu for x86-{32,64}-{newlib,freec}
Also, a couple of tests on real hardware (x86_64 only) work


# 1e13dab5 17-Jan-2012 Mark Nevill <nevillm@ethz.ch>

Added gensize_t, implemented get_address and get_size.


# b533344b 29-Dec-2011 Andrew Baumann <andrew.baumann@microsoft.com>

general cleanup of monitor internals

* start to abtract management of bindings to other monitors
(in preparation for multihop support)

* move code out of header files -- if the inlining is such a big
win, we can put it back later, but it seemed excessive

* fix a lot of irritating misnamed variables and
fields: most "closure" objects, and a lot of "st" pointers,
were in fact pointers to bindings

* deprecated num_cores_request message

* removed pingpong code from intermon interface

* removed some dead code

there should be no changes to runtime behaviour or APIs/interfaces
outside the monitor

--HG--
rename : usr/monitor/iref.h => usr/monitor/iref.c


# 52c61712 28-Dec-2011 Zeus Gómez Marmolejo <zeus.gomez@bsc.es>

Replaced caddr_t type with capaddr_t to avoid conflict with libc

for i in $(find . -type f)
do
grep -r caddr_t $i
if [ $? -eq 0 ]
then
sed 's/caddr_t/capaddr_t/g' $i > $i.sed
mv $i.sed $i
fi
done


# a6b4f894 27-Dec-2011 Andrew Baumann <andrew.baumann@microsoft.com>

rename MAX_CPUS to MAX_COREID, and increase it to 254 (to match an 8-bit coreid_t)

* Kludged around the limitations of coremask_t enough to keep rcap_db_null compiling.
* Removed the config option that allowed users to lower it. this
doesn't make much sense any more, unless we are going in for really
silly compile-time optimisations. This change requires updating
Config.hs


# 9299dcef 08-Jul-2011 Stefan Kästle <stefan.kaestle@inf.ethz.ch>

Initial version of public stable barrelfish repository.