1%define name curl-ssl
2%define tarball curl
3%define version 7.11.0
4%define release 1
5
6%define curlroot %{_builddir}/%{tarball}-%{version}
7
8Summary: get a file from an FTP or HTTP server.
9Name: %{name}
10Version: %{version}
11Release: %{release}
12Copyright: MIT/X derivate
13Vendor: Daniel Stenberg <Daniel.Stenberg@haxx.se>
14Packager: Troy Engel <tengel@sonic.net>
15Group: Utilities/Console
16Source: %{tarball}-%{version}.tar.gz
17URL: http://curl.haxx.se/
18Provides: curl
19Obsoletes: curl
20BuildRoot: %{_tmppath}/%{tarball}-%{version}-root
21Requires: openssl >= 0.9.5
22
23%description
24curl is a client to get documents/files from servers, using any of the
25supported protocols. The command is designed to work without user
26interaction or any kind of interactivity.
27
28curl offers a busload of useful tricks like proxy support, user
29authentication, ftp upload, HTTP post, file transfer resume and more.
30
31%package	devel
32Summary:	The includes, libs, and man pages to develop with libcurl
33Group:		Development/Libraries
34Requires:	openssl-devel >= 0.9.5
35Provides:	curl-devel
36
37%description devel
38libcurl is the core engine of curl; this packages contains all the libs,
39headers, and manual pages to develop applications using libcurl.
40
41%prep
42
43%setup -q -n %{tarball}-%{version}
44
45%build
46cd %{curlroot} && (if [ -f configure.in ]; then mv -f configure.in configure.in.rpm; fi)
47%configure
48cd %{curlroot} && (if [ -f configure.in.rpm ]; then mv -f configure.in.rpm configure.in; fi)
49make
50
51%install
52[ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
53make DESTDIR=%{buildroot} install-strip
54
55%clean
56[ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
57[ "%{curlroot}" != "/" ] && rm -rf %{curlroot}
58
59%post
60/sbin/ldconfig
61
62%postun
63/sbin/ldconfig
64
65%files
66%defattr(-,root,root)
67%attr(0755,root,root) %{_bindir}/curl
68%attr(0644,root,root) %{_mandir}/man1/curl.1*
69%{_libdir}/libcurl.so*
70%{_datadir}/curl/curl-ca-bundle.crt
71%doc CHANGES COPYING README testcurl.sh docs/BUGS docs/SSLCERTS
72%doc docs/CONTRIBUTE docs/FAQ docs/FEATURES docs/HISTORY docs/INSTALL
73%doc docs/KNOWN_BUGS docs/MANUAL docs/RESOURCES docs/THANKS
74%doc docs/TODO docs/VERSIONS docs/TheArtOfHttpScripting tests
75
76%files devel
77%defattr(-,root,root)
78%attr(0755,root,root) %{_bindir}/curl-config
79%attr(0644,root,root) %{_mandir}/man1/curl-config.1*
80%attr(0644,root,root) %{_mandir}/man3/*
81%attr(0644,root,root) %{_includedir}/curl/*
82%{_libdir}/libcurl.a
83%{_libdir}/libcurl.la
84%doc docs/BINDINGS docs/INTERNALS docs/examples/* docs/libcurl-the-guide
85