1#!/usr/bin/make -f
2# Sample debian/rules that uses debhelper.
3# GNU copyright 1997 to 1999 by Joey Hess.
4
5# Uncomment this to turn on verbose mode.
6#export DH_VERBOSE=1
7
8# This is the debhelper compatability version to use.
9export DH_COMPAT=1
10
11build: build-stamp
12build-stamp:
13	dh_testdir
14
15	./configure --prefix=/usr --mandir=\$${prefix}/share/man \
16		--enable-pax=pax --enable-gzip=gzip --enable-pam
17	# Add here commands to compile the package.
18	$(MAKE)
19
20	touch build-stamp
21
22clean:
23	dh_testdir
24	dh_testroot
25	rm -f build-stamp
26
27	# Add here commands to clean up after the build process.
28	-$(MAKE) distclean
29
30	dh_clean
31
32install: build
33	dh_testdir
34	dh_testroot
35	dh_clean -k
36	dh_installdirs
37
38	# Add here commands to install the package into debian/tmp.
39	$(MAKE) install DESTDIR=`pwd`/debian/tmp prefix=/usr
40
41
42# Build architecture-independent files here.
43binary-indep: build install
44# We have nothing to do by default.
45
46# Build architecture-dependent files here.
47binary-arch: build install
48#	dh_testversion
49	dh_testdir
50	dh_testroot
51#	dh_installdebconf	
52	dh_installdocs
53	dh_installexamples
54	dh_installmenu
55#	dh_installemacsen
56#	dh_installpam
57	dh_installinit
58	dh_installcron
59#	dh_installmanpages
60#	dh_installinfo
61#	dh_undocumented
62	dh_installchangelogs CHANGELOG
63	dh_link
64	dh_strip
65	dh_compress
66	dh_fixperms
67#	dh_makeshlibs
68	dh_installdeb
69#	dh_perl
70	dh_shlibdeps
71	dh_gencontrol
72	dh_md5sums
73	dh_builddeb
74
75binary: binary-indep binary-arch
76.PHONY: build clean binary-indep binary-arch binary install
77