1%define beta %nil
2%define rel 1
3Summary: The GNU versions of grep pattern matching utilities.
4Name: grep
5Version: 2.5.1
6%if "%{beta}" != ""
7Release: 0.%{beta}.%{rel}
8%else
9Release: %{rel}
10%endif
11License: GPL
12Group: Applications/Text
13Source: ftp://ftp.gnu.org/pub/gnu/grep/grep-%{version}%{beta}.tar.bz2
14Prefix: %{_prefix}
15Prereq: /sbin/install-info
16Buildroot: %{_tmppath}/%{name}-%{version}-root
17Requires: pcre
18Buildrequires: pcre-devel
19
20%description
21The GNU versions of commonly used grep utilities.  Grep searches
22through textual input for lines which contain a match to a specified
23pattern and then prints the matching lines.  GNU's grep utilities
24include grep, egrep and fgrep.
25
26You should install grep on your system, because it is a very useful
27utility for searching through text.
28
29%prep
30%setup -q -n %{name}-%{version}%{beta}
31
32%build
33[ ! -e configure ] && ./autogen.sh
34%configure --prefix=/usr --without-included-regex
35make
36
37%install
38rm -rf ${RPM_BUILD_ROOT}
39%makeinstall LDFLAGS=-s prefix=${RPM_BUILD_ROOT}%{_prefix} exec_prefix=${RPM_BUILD_ROOT}
40%ifos Linux
41mkdir -p $RPM_BUILD_ROOT/bin
42mv $RPM_BUILD_ROOT%{_prefix}/bin/* $RPM_BUILD_ROOT/bin
43rm -rf $RPM_BUILD_ROOT%{_prefix}/bin
44%endif
45gzip -9f $RPM_BUILD_ROOT%{_infodir}/grep*
46
47%find_lang %name
48
49%clean
50rm -rf ${RPM_BUILD_ROOT}
51
52%post
53[ -e %{_infodir}/grep.info.gz ] && /sbin/install-info --quiet --info-dir=%{_infodir} %{_infodir}/grep.info.gz || :
54
55%preun
56if [ $1 = 0 ]; then
57	[ -e %{_infodir}/grep.info.gz ] && /sbin/install-info --quiet --info-dir=%{_infodir} --delete %{_infodir}/grep.info.gz
58fi
59
60%files -f %{name}.lang
61%defattr(-,root,root)
62%doc ABOUT-NLS AUTHORS THANKS TODO NEWS README ChangeLog
63
64%ifos Linux
65/bin/*
66%else
67%{_prefix}/bin/*
68%endif
69%{_infodir}/*.info.gz
70%{_mandir}/*/*
71
72%changelog
73* Tue Mar 26 2002 Bernhard Rosenkraenzer <bero@redhat.com> 2.5.1-1
74- 2.5.1
75
76* Wed Mar 13 2002 Bernhard Rosenkraenzer <bero@redhat.com> 2.5-1
77- 2.5 final
78
79* Wed Jan 23 2002 Bernhard Rosenkraenzer <bero@redhat.com> 2.5-0.g.1
80- 2.5g
81
82* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
83- automated rebuild
84
85* Mon Nov 19 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.5-0.f.4
86- Update CVS to reduce bloat
87
88* Thu Nov  8 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.5-0.f.3
89- Don't fail %%post with --excludedocs
90
91* Wed Sep 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.5-0.f.2
92- Fix up echo A |grep '[A-Z0-9]' in locales other than C
93
94* Tue Sep 25 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.5-0.f.1
95- 2.5f, fixes #53603
96
97* Wed Jul 18 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.4.2-7
98- Fix up the i18n patch - it used to break "grep '[]a]'" (#49003)
99- revert to 2.4.2 (latest official release) for now
100
101* Mon May 28 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.5e-4
102- Fix "echo Linux forever |grep -D skip Linux"
103
104* Mon May 21 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.5e-3
105- Add new -D, --devices option
106- Fix a bug with "directories" being uninitialized
107
108* Sun May 13 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.5e-2
109- Fix up the --color option to behave like the one from ls (--color=auto)
110  Sooner or later, some people will alias grep="grep --color" and wonder why
111  their scripts break.
112- Update docs accordingly
113- Get rid of the annoying blinking in grep --color
114
115* Sun May 13 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.5e-1
116- 2.5e
117
118* Tue Feb 27 2001 Trond Eivind Glomsr�d <teg@redhat.com>
119- use %%{_tmppath}
120- langify
121
122* Sun Aug 20 2000 Jakub Jelinek <jakub@redhat.com>
123- i18n character ranges patch from Ulrich Drepper
124
125* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
126- automatic rebuild
127
128* Mon Jun 19 2000 Bernhard Rosenkraenzer <bero@redhat.com>
129- FHSify
130
131* Tue Mar 21 2000 Florian La Roche <Florian.LaRoche@redhat.com>
132- update to 2.4.2
133- fix download URL
134
135* Thu Feb 03 2000 Bernhard Rosenkraenzer <bero@redhat.com>
136- gzip info pages (Bug #9035)
137
138* Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
139- fix description
140
141* Wed Dec 22 1999 Jeff Johnson <jbj@redhat.com>
142- update to 2.4.
143
144* Wed Oct 20 1999 Bill Nottingham <notting@redhat.com>
145- prereq install-info
146
147* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com> 
148- auto rebuild in the new build environment (release 2)
149
150* Mon Mar 08 1999 Preston Brown <pbrown@redhat.com>
151- upgraded to grep 2.3, added install-info %post/%preun for info
152
153* Wed Feb 24 1999 Preston Brown <pbrown@redhat.com>
154- Injected new description and group.
155
156* Sat May 09 1998 Prospector System <bugs@redhat.com>
157- translations modified for de, fr, tr
158
159* Fri May 01 1998 Cristian Gafton <gafton@redhat.com>
160- updated to 2.2
161
162* Thu Oct 16 1997 Donnie Barnes <djb@redhat.com>
163- updated from 2.0 to 2.1
164- spec file cleanups
165- added BuildRoot
166
167* Mon Jun 02 1997 Erik Troan <ewt@redhat.com>
168- built against glibc
169