1%define name metakit
2%define ver 2.0
3%define extension tar.gz
4
5Summary: The Metakit Library 2.0
6Name: %{name}
7Version: %{ver}
8Release: 1
9Copyright: GPL
10Group: Applications/Databases
11Source: %{name}-%{ver}.%{extension}
12Patch: metakit-install.patch
13URL: http://www.equi4.com/metakit/
14Buildroot: /tmp/%{name}-%{ver}-root
15Packager: Sean Summers <rpm-metakit@GeneralProtectionfault.com>
16
17%description
18Metakit is an embeddable database which runs on Unix, Windows,
19Macintosh, and other platforms.  It lets you build applications which
20store their data efficiently, in a portable way, and which will not need a
21complex runtime installation.  In terms of the data model, Metakit takes
22the middle ground between RDBMS, OODBMS, and flat-file databases - yet it
23is quite different from each of them.
24
25WHAT IT ISN'T - Metakit is not: 1) an SQL database, 2) multi-user/-threading,
263) scalable to gigabytes, 4) proprietary software, 5) a toy.
27
28%package devel
29Summary: Development Libraries for The Metakit Library 2.0
30Group: Development/Libraries
31%description devel
32The %{name}-devel package contains the libraries and header files necessary
33for writing programs that make use of the Metakit library.
34
35%package python
36Group: Development/Libraries
37Summary: Python module for The Metakit Library 2.0
38%description python
39The %{name}-python package contains the libraries necessary
40for using the Metakit as a python module.
41
42#%package tcl
43#Group: Development/Libraries
44#Summary: TCL module for The Metakit Library 2.0
45#%description tcl
46#The %{name}-tcl package contains the libraries necessary
47#for using the Metakit as a tcl module.
48
49%prep
50%setup
51%patch -p1
52
53%build
54cd builds
55../unix/configure --prefix=/usr --with-python
56#--with-tcl ## maybe TCL_DECLARE_MUTEX is too new for RH6.1.92?
57make ${RPM_BUILD_OPTS}
58
59# Testing takes a while
60rm tests/\!keepme.txt
61make ${RPM_BUILD_OPTS} test
62
63%install
64cd builds
65make install DESTDIR=${RPM_BUILD_ROOT}
66libtool --finish ${RPM_BUILD_ROOT}/usr/lib/
67
68#python setup
69make Mk4py.so
70install -Ds Mk4py.so ${RPM_BUILD_ROOT}/usr/lib/python1.5/site-packages/Mk4pymodule.so
71
72#%install tcl
73#make Mk4tcl.so
74
75%clean
76rm -rf $RPM_BUILD_ROOT
77
78%files
79%doc CHANGES README Metakit.html
80%doc doc/e4s.gif doc/format.html
81/usr/lib/libmk4.so
82/usr/lib/libmk4.so.0
83/usr/lib/libmk4.so.0.0.0
84/usr/lib/libmk4.la
85
86%files devel
87%doc doc/api/ demos/
88/usr/lib/libmk4.a
89/usr/include/mk4.h
90/usr/include/mk4.inl
91/usr/include/mk4str.h
92/usr/include/mk4str.inl
93
94%files python
95%doc python/*.py
96%doc doc/python.*
97/usr/lib/python1.5/site-packages/Mk4pymodule.so
98
99#%files tcl
100#%doc tcl/*.tcl
101#%doc doc/tcl.*
102#/usr/lib/tcl
103
104