1# $Id: tcl.spec,v 1.16.2.19 2008/04/11 16:57:42 dgp Exp $
2# This file is the basis for a binary Tcl RPM for Linux.
3
4%define version 8.4.19
5%define directory /usr/local
6
7Summary: Tcl scripting language development environment
8Name: tcl
9Version: %{version}
10Release: 1
11Copyright: BSD
12Group: Development/Languages
13Source: http://prdownloads.sourceforge.net/tcl/tcl%{version}-src.tar.gz
14URL: http://www.tcl.tk/
15Packager: Carina
16Buildroot: /var/tmp/%{name}%{version}
17
18%description
19The Tcl (Tool Command Language) provides a powerful platform for
20creating integration applications that tie together diverse
21applications, protocols, devices, and frameworks.  When paired with
22the Tk toolkit, Tcl provides the fastest and most powerful way to
23create GUI applications that run on PCs, Unix, and the Macintosh.  Tcl
24can also be used for a variety of web-related tasks and for creating
25powerful command languages for applications.
26
27%prep
28
29%build
30./configure --prefix %{directory} --exec-prefix %{directory}
31make CFLAGS=$RPM_OPT_FLAGS
32
33%install
34rm -rf $RPM_BUILD_ROOT
35make INSTALL_ROOT=$RPM_BUILD_ROOT install
36
37%clean
38rm -rf $RPM_BUILD_ROOT
39
40# to create the tcl files list, comment out tk in the install section above,
41# then run "rpm -bi" then do a find from the build root directory,
42# and remove the files in specific directories which suffice by themselves,
43# then to create the files list for tk, uncomment tk, comment out tcl,
44# then rm -rf $RPM_BUILD_ROOT then rpm --short-circuit -bi then redo a find,
45# and remove the files in specific directories which suffice by themselves.
46%files
47%defattr(-,root,root)
48%{directory}/lib
49%{directory}/bin
50%{directory}/include
51%{directory}/man/man1
52%{directory}/man/man3
53%{directory}/man/mann
54