1220747Snwhitehorn#!/usr/bin/make -f
2220747Snwhitehorn# MAde with the aid of dh_make, by Craig Small
3220747Snwhitehorn# Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
4220747Snwhitehorn# Some lines taken from debmake, by Cristoph Lameter.
5220747Snwhitehorn
6220747Snwhitehorn# Uncomment this to turn on verbose mode.
7220747Snwhitehorn#export DH_VERBOSE=1
8220747Snwhitehorn
9220747Snwhitehorn# These are used for cross-compiling and for saving the configure script
10220747Snwhitehorn# from having to guess our platform (since we know it already)
11220747SnwhitehornDEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
12220747SnwhitehornDEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
13220747Snwhitehorn
14220747SnwhitehornCFLAGS =
15220747Snwhitehorn
16220747Snwhitehornifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
17220747Snwhitehorn        CFLAGS += -O0
18220747Snwhitehornelse
19220747Snwhitehorn        CFLAGS += -O2
20220747Snwhitehornendif
21220747Snwhitehornifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
22220747Snwhitehorn        INSTALL_PROGRAM += -s
23220747Snwhitehornendif
24220747Snwhitehorn
25220747Snwhitehorn
26220747Snwhitehornconfigure: configure-stamp
27220747Snwhitehornconfigure-stamp:
28220747Snwhitehorn	dh_testdir
29220747Snwhitehorn
30220747Snwhitehorn	CFLAGS="$(CFLAGS)" ./configure \
31220747Snwhitehorn		--host=$(DEB_HOST_GNU_TYPE) \
32220747Snwhitehorn		--build=$(DEB_BUILD_GNU_TYPE) \
33220747Snwhitehorn		--prefix=/usr \
34220747Snwhitehorn		--mandir=\$${prefix}/share/man \
35220747Snwhitehorn		--enable-nls \
36220747Snwhitehorn		--enable-header-subdir \
37220747Snwhitehorn		--enable-widec \
38220747Snwhitehorn		--with-libtool \
39220747Snwhitehorn		--with-ncursesw \
40220747Snwhitehorn		--with-package=cdialog \
41220747Snwhitehorn		--disable-rpath-hack
42220747Snwhitehorn
43220747Snwhitehorn	touch configure-stamp
44220747Snwhitehorn
45220747Snwhitehornbuild: build-stamp
46220747Snwhitehornbuild-stamp: configure-stamp
47220747Snwhitehorn	dh_testdir
48220747Snwhitehorn
49220747Snwhitehorn	$(MAKE)
50220747Snwhitehorn
51220747Snwhitehorn	touch build-stamp
52220747Snwhitehorn
53220747Snwhitehornclean:
54220747Snwhitehorn	dh_testdir
55220747Snwhitehorn	dh_testroot
56220747Snwhitehorn
57220747Snwhitehorn	[ ! -f makefile ] || $(MAKE) distclean
58220747Snwhitehorn
59220747Snwhitehorn	rm -f configure-stamp build-stamp install-stamp
60220747Snwhitehorn
61220747Snwhitehorn	dh_clean
62220747Snwhitehorn
63220747Snwhitehorninstall: install-stamp
64220747Snwhitehorninstall-stamp: build-stamp
65220747Snwhitehorn	dh_testdir
66220747Snwhitehorn	dh_testroot
67220747Snwhitehorn	dh_clean -k
68220747Snwhitehorn	dh_installdirs
69220747Snwhitehorn
70220747Snwhitehorn	$(MAKE) install DESTDIR=$(CURDIR)/debian/cdialog
71220747Snwhitehorn
72220747Snwhitehorn	touch install-stamp
73220747Snwhitehorn
74220747Snwhitehorn# Build architecture-independent files here.
75220747Snwhitehornbinary-indep: build install
76220747Snwhitehorn# No binary-indep target.
77220747Snwhitehorn
78220747Snwhitehorn# Build architecture-dependent files here.
79220747Snwhitehornbinary-arch: build install
80220747Snwhitehorn	dh_testdir
81220747Snwhitehorn	dh_testroot
82220747Snwhitehorn	dh_installdocs
83220747Snwhitehorn	dh_installexamples
84220747Snwhitehorn	dh_installchangelogs CHANGES
85220747Snwhitehorn	dh_strip
86220747Snwhitehorn	dh_compress
87220747Snwhitehorn	dh_fixperms
88220747Snwhitehorn	dh_installdeb
89220747Snwhitehorn	dh_shlibdeps
90220747Snwhitehorn	dh_gencontrol
91220747Snwhitehorn	dh_md5sums
92220747Snwhitehorn	dh_builddeb
93220747Snwhitehorn
94220747Snwhitehornbinary: binary-indep binary-arch
95220747Snwhitehorn.PHONY: build clean binary-indep binary-arch binary install install-stamp
96