1257313SbaptSummary: byacc - public domain Berkeley LALR Yacc parser generator
2257313Sbapt%define AppProgram byacc
3319349Sjkim%define AppVersion 20170201
4257313Sbapt%define UseProgram yacc
5319349Sjkim# $XTermId: mingw-byacc.spec,v 1.15 2017/02/01 09:55:04 tom Exp $
6257313SbaptName: %{AppProgram}
7257313SbaptVersion: %{AppVersion}
8257313SbaptRelease: 1
9257313SbaptLicense: Public Domain, MIT
10257313SbaptGroup: Applications/Development
11257313SbaptURL: ftp://invisible-island.net/%{AppProgram}
12257313SbaptSource0: %{AppProgram}-%{AppVersion}.tgz
13257313SbaptPackager: Thomas Dickey <dickey@invisible-island.net>
14257313Sbapt
15257313Sbapt%description
16257313SbaptThis package provides a parser generator utility that reads a grammar
17257313Sbaptspecification from a file and generates an LR(1) parser for it.  The
18257313Sbaptparsers consist of a set of LALR(1) parsing tables and a driver
19257313Sbaptroutine written in the C programming language.  It has a public domain
20257313Sbaptlicense which includes the generated C.
21257313Sbapt
22257313Sbapt%prep
23257313Sbapt
24257313Sbapt%setup -q -n %{AppProgram}-%{AppVersion}
25257313Sbapt
26257313Sbapt%build
27257313Sbapt
28257313SbaptINSTALL_PROGRAM='${INSTALL}' \
29257313Sbapt	./configure \
30257313Sbapt		--program-prefix=b \
31257313Sbapt		--target %{_target_platform} \
32257313Sbapt		--prefix=%{_prefix} \
33257313Sbapt		--bindir=%{_bindir} \
34257313Sbapt		--libdir=%{_libdir} \
35257313Sbapt		--mandir=%{_mandir}
36257313Sbapt
37257313Sbaptmake
38257313Sbapt
39257313Sbapt%install
40257313Sbapt[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
41257313Sbapt
42257313Sbaptmake install                    DESTDIR=$RPM_BUILD_ROOT
43257313Sbapt( cd $RPM_BUILD_ROOT%{_bindir} && ln -s %{AppProgram} %{UseProgram} )
44257313Sbapt
45257313Sbaptstrip $RPM_BUILD_ROOT%{_bindir}/%{AppProgram}
46257313Sbapt
47257313Sbapt%clean
48257313Sbapt[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
49257313Sbapt
50257313Sbapt%files
51257313Sbapt%defattr(-,root,root)
52257313Sbapt%{_prefix}/bin/%{AppProgram}
53257313Sbapt%{_prefix}/bin/%{UseProgram}
54257313Sbapt%{_mandir}/man1/%{AppProgram}.*
55257313Sbapt
56257313Sbapt%changelog
57257313Sbapt# each patch should add its ChangeLog entries here
58257313Sbapt
59257313Sbapt* Wed Sep 25 2013 Thomas Dickey
60257313Sbapt- cloned from byacc.spec
61