1Summary: PPP Over Ethernet (xDSL support)
2Name: rp-pppoe
3Version: 3.11
4%if %(%{expand:test %{_vendor} != mandrake ; echo $?})
5Release: 1mdk
6%else
7Release: 1
8%endif
9License: GPL
10Group: System Environment/Daemons
11Source: http://www.roaringpenguin.com/penguin/pppoe/rp-pppoe-3.10.tar.gz
12Url: http://www.roaringpenguin.com/pppoe/
13Packager: David F. Skoll <dfs@roaringpenguin.com>
14BuildRoot: /tmp/pppoe-build
15Vendor: Roaring Penguin Software Inc.
16Requires: ppp >= 2.3.7
17
18# LIC: GPL
19%description
20PPPoE (Point-to-Point Protocol over Ethernet) is a protocol used by
21many DSL Internet Service Providers. Roaring Penguin has a free
22client for Linux systems to connect to PPPoE service providers.
23
24The client is a user-mode program and does not require any kernel
25modifications. It is fully compliant with RFC 2516, the official PPPoE
26specification.
27
28%prep
29%setup
30cd src
31./configure --mandir=%{_mandir}
32
33%build
34cd src
35make
36cd ../gui
37make
38
39%install
40umask 022
41cd src
42make install DESTDIR=$RPM_BUILD_ROOT
43mkdir -p $RPM_BUILD_ROOT/etc/init.d
44test -f $RPM_BUILD_ROOT/etc/init.d/pppoe || cp ../scripts/pppoe-init $RPM_BUILD_ROOT/etc/init.d/pppoe
45chmod 755 $RPM_BUILD_ROOT/etc/init.d/pppoe
46cd ../gui
47make install DESTDIR=$RPM_BUILD_ROOT
48rm -f $RPM_BUILD_ROOT/etc/ppp/pppoe.conf-3.10
49rm -f $RPM_BUILD_ROOT/etc/ppp/firewall-masq-3.10
50rm -f $RPM_BUILD_ROOT/etc/ppp/firewall-standalone-3.10
51rm -f $RPM_BUILD_ROOT/etc/ppp/pppoe-server-options-example
52
53%clean
54rm -rf $RPM_BUILD_ROOT
55
56%files
57%defattr(-,root,root)
58%doc doc/CHANGES doc/HOW-TO-CONNECT doc/LICENSE doc/KERNEL-MODE-PPPOE README SERVPOET
59%config(noreplace) /etc/ppp/pppoe.conf
60%config(noreplace) /etc/ppp/pppoe-server-options
61%config(noreplace) /etc/ppp/firewall-masq
62%config(noreplace) /etc/ppp/firewall-standalone
63/etc/ppp/plugins/*
64/usr/sbin/pppoe
65/usr/sbin/pppoe-server
66/usr/sbin/pppoe-sniff
67/usr/sbin/pppoe-relay
68/usr/sbin/pppoe-connect
69/usr/sbin/pppoe-start
70/usr/sbin/pppoe-stop
71/usr/sbin/pppoe-setup
72/usr/sbin/pppoe-status
73%{_mandir}/man5/pppoe.conf.5*
74%{_mandir}/man8/pppoe.8*
75%{_mandir}/man8/pppoe-server.8*
76%{_mandir}/man8/pppoe-relay.8*
77%{_mandir}/man8/pppoe-sniff.8*
78%{_mandir}/man8/pppoe-connect.8*
79%{_mandir}/man8/pppoe-start.8*
80%{_mandir}/man8/pppoe-stop.8*
81%{_mandir}/man8/pppoe-status.8*
82%{_mandir}/man8/pppoe-setup.8*
83/etc/init.d/pppoe
84%package gui
85Summary: Tk PPP Over Ethernet Client (xDSL support)
86Group: System Environment/Daemons
87Requires: rp-pppoe
88Requires: tk
89
90%description gui
91This is a graphical wrapper around the rp-pppoe PPPoE client.  PPPoE is
92a protocol used by many DSL Internet Service Providers.
93
94%post gui
95# Install entry in KDE menu
96if test -n "$KDEDIR" ; then
97    mkdir -p "$KDEDIR/share/applnk/Internet"
98    cat <<EOF > "$KDEDIR/share/applnk/Internet/tkpppoe.kdelnk"
99# KDE Config File
100[KDE Desktop Entry]
101Name=TkPPPoE
102Comment=Start/Stop PPPoE connections
103Exec=tkpppoe
104Terminal=0
105Type=Application
106EOF
107fi
108
109# Install entry in GNOME menus
110GNOMEDIR=`gnome-config --datadir 2>/dev/null`
111if test -n "$GNOMEDIR" ; then
112    mkdir -p "$GNOMEDIR/gnome/apps/Internet"
113cat <<EOF > "$GNOMEDIR/gnome/apps/Internet/tkpppoe.desktop"
114[Desktop Entry]
115Name=TkPPPoE
116Comment=Start/Stop PPPoE connections
117Exec=tkpppoe
118Terminal=0
119Type=Application
120EOF
121fi
122
123%postun gui
124# Remove KDE menu entry
125if test -n "$KDEDIR" ; then
126    rm -f "$KDEDIR/share/applnk/Internet/tkpppoe.kdelnk"
127fi
128
129# Remove GNOME menu entry
130GNOMEDIR=`gnome-config --datadir 2>/dev/null`
131if test -n "$GNOMEDIR" ; then
132    rm -f "$GNOMEDIR/gnome/apps/Internet/tkpppoe.desktop"
133fi
134
135%files gui
136%defattr(-,root,root)
137%dir /etc/ppp/rp-pppoe-gui
138/usr/sbin/pppoe-wrapper
139/usr/bin/tkpppoe
140%{_mandir}/man1/tkpppoe.1*
141%{_mandir}/man1/pppoe-wrapper.1*
142/usr/share/tkpppoe/tkpppoe.html
143/usr/share/tkpppoe/mainwin-busy.png
144/usr/share/tkpppoe/mainwin-nonroot.png
145/usr/share/tkpppoe/mainwin.png
146/usr/share/tkpppoe/props-advanced.png
147/usr/share/tkpppoe/props-basic.png
148/usr/share/tkpppoe/props-nic.png
149/usr/share/tkpppoe/props-options.png
150/usr/share/tkpppoe/en.msg
151/usr/share/tkpppoe/ja.msg
152
153%changelog
154* Thu Jul 21 2001 Shigechika AIKAWA <shige@cin.nihon-u.ac.jp>
155- merged rp-pppoe.spec and rp-pppoe-gui.spec
156