1# $Id: bridge-utils.spec,v 1.1.1.1 2008/10/15 03:28:31 james26_jang Exp $
2
3Summary: Utilities for configuring the linux ethernet bridge.
4Name: bridge-utils
5Version: 0.9.1
6Release: 1
7Copyright: GPL
8Group: Applications/System
9Source0: ftp://openrock.net/bridge/bridge-utils-%{PACKAGE_VERSION}.tar.gz
10BuildRoot: /var/tmp/%{name}-root
11
12%description
13This package contains utilities for configuring the linux ethernet
14bridge. The linux ethernet bridge can be used for connecting multiple
15ethernet devices together. The connecting is fully transparent: hosts
16connected to one ethernet device see hosts connected to the other
17ethernet devices directly.
18
19Install bridge-utils if you want to use the linux ethernet bridge.
20
21%package -n bridge-utils-devel
22Summary: Utilities for configuring the linux ethernet bridge.
23Group: Development/Libraries
24
25%description -n bridge-utils-devel
26The bridge-utils-devel package contains the header and object files
27necessary for developing programs which use 'libbridge.a', the
28interface to the linux kernel ethernet bridge. If you are developing
29programs which need to configure the linux ethernet bridge, your
30system needs to have these standard header and object files available
31in order to create the executables.
32
33Install bridge-utils-devel if you are going to develop programs which
34will use the linux ethernet bridge interface library.
35
36%prep
37%setup -n bridge
38
39%build
40make
41
42%install
43rm -rf $RPM_BUILD_ROOT
44mkdir -p ${RPM_BUILD_ROOT}
45mkdir -p ${RPM_BUILD_ROOT}/sbin
46mkdir -p ${RPM_BUILD_ROOT}/usr/include
47mkdir -p ${RPM_BUILD_ROOT}/usr/lib
48mkdir -p ${RPM_BUILD_ROOT}/usr/man/man8
49mkdir -p ${RPM_BUILD_ROOT}/usr/sbin
50strip brctl/brctl
51cp brctl/brctl ${RPM_BUILD_ROOT}/sbin
52cp doc/brctl.8 ${RPM_BUILD_ROOT}/usr/man/man8
53cp libbridge/libbridge.h ${RPM_BUILD_ROOT}/usr/include
54cp libbridge/libbridge.a ${RPM_BUILD_ROOT}/usr/lib
55
56%clean
57rm -rf ${RPM_BUILD_ROOT}
58
59%files
60%defattr (-,root,root)
61%doc AUTHORS COPYING doc/FAQ doc/HOWTO doc/RPM-GPG-KEY
62/sbin/brctl
63/usr/man/man8/brctl.8
64
65%files -n bridge-utils-devel
66%defattr (-,root,root)
67/usr/include/libbridge.h
68/usr/lib/libbridge.a
69