Lines Matching refs:be

11  * This code is distributed in the hope that it will be useful, but WITHOUT
47 "Multple reference types will be returned if two or more class "
114 "may be used as the first step in building a tree (or trees) of the "
177 "VM. All Java threads currently running will be suspended. "
181 "counted. Before a thread will run again, it must be resumed through "
208 "On some platforms, the exit code might be truncated, for "
291 "count) will be decremented by refCnt. "
295 "be freed, and if garbage collection was "
296 "disabled for the object, it will be re-enabled. "
298 "promises that no further commands will be sent "
302 "resources associated with each ID will be freed by the back-end "
307 "for example) but may not be garbage collected any time soon. "
309 "IDs may be re-used by the back-end after they "
339 "execution may be frozen by the debugger back-end to prevent "
456 "redefined classes will be used for new invokes in the target VM. "
460 "<a href=\"#JDWP_StackFrame_PopFrames\">PopFrames</a> command can be used "
556 (Repeat refTypesCount "Number of reference types that follow. Must be non-negative."
721 "reference type. Each field must be member of the reference type "
724 "fields can be obtained."
793 "will be set. If the class is initialized the INITIALIZED bit in the returned "
794 "status bits will be set. If an error occured during initialization then the "
795 "ERROR bit in the returned status bits will be set. "
981 (int maxInstances "Maximum number of instances to return. Must be non-negative. "
1082 "Each field must be member of the class type "
1085 "fields can be set. Final fields cannot be set."
1089 "field's type and the field's type must be loaded. "
1112 "The method must be member of the class type "
1115 "methods can be invoked."
1136 "argument's type and the argument's type must be loaded. "
1143 "that will be needed by the invoked method. It is possible that "
1152 "The resumption of other threads during the invoke can be prevented "
1156 "described above, so this option should be used with great caution. "
1157 "Only the specified thread will be resumed (as described for all "
1159 "will be suspended once again. Note that any threads started during "
1160 "the single threaded invocation will not be suspended when the "
1190 "constructor. The constructor method ID must be a member of "
1212 "argument's type and the argument's type must be loaded. "
1219 "that will be needed by the invoked method. It is possible that "
1228 "The resumption of other threads during the invoke can be prevented "
1232 "described above, so this option should be used with great caution. "
1233 "Only the specified thread will be resumed (as described for all "
1235 "will be suspended once again. Note that any threads started during "
1236 "the single threaded invocation will not be suspended when the "
1287 "The method must not be a static initializer. "
1288 "The method must be a member of the interface type. "
1310 "argument's type and the argument's type must be loaded. "
1317 "that will be needed by the invoked method. It is possible that "
1326 "The resumption of other threads during the invoke can be prevented "
1330 "described above, so this option should be used with great caution. "
1331 "Only the specified thread will be resumed (as described for all "
1333 "will be suspended once again. Note that any threads started during "
1334 "the single threaded invocation will not be suspended when the "
1398 "table. Also, synthetic variables may be present. "
1411 "The variable can be get or set only when the current "
1417 "The variable can be get or set only when the current "
1487 "table. Also, synthetic variables may be present. "
1504 "The variable can be get or set only when the current "
1512 "The variable can be get or set only when the current "
1534 "The runtime type will be a class or an array. "
1550 "Each field must be member of the object's type "
1553 "fields can be obtained."
1578 "Each field must be member of the object's type "
1581 "fields can be set. "
1583 "field's type exactly. For object values, there must be a "
1585 "field's type and the field's type must be loaded. "
1605 "be suspended."
1627 "The method must be member of the object's type "
1630 "methods can be invoked."
1649 "argument's type exactly. For object arguments, there must be a "
1651 "argument's type and the argument's type must be loaded. "
1658 "that will be needed by the invoked method. It is possible that "
1667 "The resumption of other threads during the invoke can be prevented "
1671 "described above, so this option should be used with great caution. "
1672 "Only the specified thread will be resumed (as described for all "
1674 "will be suspended once again. Note that any threads started during "
1675 "the single threaded invocation will not be suspended when the "
1708 "default all objects in back-end replies may be "
1710 "this command guarantees that the object will not be "
1713 "command can be used to "
1722 "This method should be used sparingly, as it alters the "
1739 "and hence may be garbage collected. A call to this command is "
1770 "Note that an object can also be referenced in other ways, "
1778 "Must be non-negative. If zero, all referring "
1831 "a thread will run again, it must be resumed the same number "
1916 "and so on. The thread must be suspended, and the returned "
1941 "The thread must be suspended, and the returned "
1958 "The thread must be suspended, and the returned information is "
1979 "thread may be waiting to enter a monitor, or it may be waiting, via "
1982 "The thread must be suspended, and the returned information is "
2006 "be an instance of java.lang.Throwable or a subclass")
2051 "The thread must be suspended, and the returned information is "
2086 "The specified thread must be suspended. "
2102 "Events, such as MethodExit, are generated as they would be in "
2105 "The called method must be a non-native Java programming "
2109 "For void methods, the value must be a void value. "
2111 "match the return type exactly. For object values, there must be a "
2113 "return type type and the return type must be loaded. "
2215 "be within the bounds of the array. "
2235 "be within the bounds of the array. "
2237 "array component type exactly. For object values, there must be a "
2239 "array component type and the array component type must be loaded. "
2260 "been requested to load. This class loader is considered to be "
2270 "this class loader must be resolved to that single type. "
2304 "for a complete list of events that can be requested; "
2305 "some events may require a capability in order to be requested. "
2314 "VM, the reply to the resume command will be written to "
2335 "Limit the requested event to be reported at most once after a "
2341 "are applied. If none of those filters cause the event to be "
2345 "This modifier can be used with any event kind."
2355 "This modifier can be used with any event kind "
2362 "generated by this request to be the "
2370 "An event will be generated for any location in a reference type that can "
2371 "be safely cast to the given reference type. "
2372 "This modifier can be used with any event kind except "
2386 "This modifier can be used with any event kind except "
2406 "This modifier can be used with any event kind except "
2419 "This modifier can be used with "
2428 "This modifier can be used with "
2452 "This modifier can be used with "
2462 "This modifier can be used with "
2475 "This modifier can be used with any event kind "
2488 "This modifier can only be used with class prepare "
2524 "for a complete list of events that can be cleared. Only the event request matching "
2527 "generated events do not have a corresponding event request and may not be cleared "
2554 "given frame. Each variable must be visible at the frame's code index. "
2556 "be retrieved if the front-end is able to "
2558 "index can be determined for method arguments from the method "
2587 "Each variable must be visible at the current frame code index. "
2589 "variable's type exactly. For object values, there must be a "
2591 "variable's type and the variable's type must be loaded. "
2594 "be set, if the front-end is able to "
2596 "index can be determined for method arguments from the method "
2637 "The thread must be suspended to perform this command. "
2716 "For example, there may be more than one breakpoint request "
2784 "This means they do not need to be requested using the "
2790 "also be requested using the EventRequest.Set command and thus multiple events "
2791 "of the same event kind will be sent from the target VM when an event occurs."
2874 (value value "Value that will be returned by the method")
2891 "after waiting for it to be released by another thread. "
2945 "is considered to be caught if, at the point of the throw, the "
2954 "it is not possible to predict whether an exception will be handled "
2957 "here will, in fact, be handled by a native method and not cause "
2958 "termination of the target VM. Furthermore, it cannot be assumed that the "
2959 "catch location returned here will ever be reached by the throwing "
2962 "the exception might be handled and cleared in that native method "
2971 "will be considered caught even though it appears to be uncaught from "
2977 "The new thread can be the result of a call to "
3006 "about the lifetime of the thread object. It may or may not be collected "
3022 "to prevent these events, but they cannot be avoided under some "
3029 "all threads will be suspended instead, and the "
3082 (value valueToBe "Value to be assigned")
3114 (Constant NOT_CURRENT_FRAME =33 "Operation can only be performed on current frame.")
3126 "or otherwise cannot be interpreted as a class file.")
3169 "virtual machine. JVMTI cannot be used.")
3174 "Calls must be made from attached threads.")