• Home
  • History
  • Annotate
  • Raw
  • Download
  • only in /netgear-R7000-V1.0.7.12_1.2.5/ap/gpl/samba-3.0.25b/packaging/Mandrake/

Lines Matching refs:smb

218 %global client_sbin 	mount.smb,mount.smbfs
283 Source11: smb-migrate.bz2
335 allows samba's smb.conf file to be remotely managed using your
343 Please read the smb.conf file and ENCRYPTION.txt in the
385 allows samba's smb.conf file to be remotely managed using your
393 Please read the smb.conf file and ENCRYPTION.txt in the
493 SWAT (the Samba Web Administration Tool) allows samba's smb.conf file
497 your smb.conf file. Webmin uses SSL encryption by default, and
572 the correct operation of tools against smb servers.
1115 install -m755 packaging/Mandrake/smb.init $RPM_BUILD_ROOT/%{_initrddir}/smb%{samba_major}
1116 install -m755 packaging/Mandrake/smb.init $RPM_BUILD_ROOT/%{_sbindir}/%{name}
1158 cat packaging/Mandrake/smb.conf|sed -e 's/^; winbind/ winbind/g;s/^; obey pam/ obey pam/g; s/^; printer admin = @"D/ printer admin = @"D/g;s/^; password server = \*/ password server = \*/g;s/^; template/ template/g; s/^ security = user/ security = domain/g' > packaging/Mandrake/smb-winbind.conf
1159 install -m644 packaging/Mandrake/smb-winbind.conf $RPM_BUILD_ROOT/%{_sysconfdir}/%{name}/smb-winbind.conf
1161 # Some inline fixes for smb.conf for non-winbind use
1162 install -m644 packaging/Mandrake/smb.conf $RPM_BUILD_ROOT/%{_sysconfdir}/%{name}/smb.conf
1163 cat packaging/Mandrake/smb.conf | \
1164 sed -e 's/^; printer admin = @adm/ printer admin = @adm/g' >$RPM_BUILD_ROOT/%{_sysconfdir}/%{name}/smb.conf
1166 perl -pi -e 's/printcap name = lpstat/printcap name = cups/g' $RPM_BUILD_ROOT/%{_sysconfdir}/%{name}/smb.conf
1167 perl -pi -e 's/printcap name = lpstat/printcap name = cups/g' $RPM_BUILD_ROOT/%{_sysconfdir}/%{name}/smb-winbind.conf
1171 # Fix script paths in smb.conf
1172 #perl -pi -e 's,%{_datadir}/samba,%{_datadir}/%{name},g' %{buildroot}/%{_sysconfdir}/%{name}/smb*.conf
1184 ln -s %{_bindir}/smbspool%{alternative_major} $RPM_BUILD_ROOT/%{_libdir}/cups/backend/smb%{alternative_major}
1218 bzcat %{SOURCE11}> $RPM_BUILD_ROOT%{_datadir}/%{name}/scripts/smb-migrate
1225 for OLD in %{buildroot}/%{_bindir}/{%{clientbin}} %{buildroot}/bin/%{client_bin} %{buildroot}/%{_libdir}/cups/backend/smb
1242 # Link smbmount to /sbin/mount.smb and /sbin/mount.smbfs
1245 ln -s ..%{_bindir}/smbmount%{alternative_major} mount.smb%{alternative_major}
1256 for OLD in %{buildroot}/%{_mandir}/man?/{%{commonbin},%{serverbin},%{serversbin},swat,{%testbin},smb.conf,lmhosts}*
1268 for i in smb ;do
1271 for i in %{_sysconfdir}/%{name}/smb.conf %{_initrddir}/smb%{samba_major} %{_sbindir}/%{name} %{_initrddir}/winbind /%{_sysconfdir}/logrotate.d/%{name} /%{_sysconfdir}/xinetd.d/swat%{samba_major} %{_initrddir}/wrepld%{samba_major}; do
1283 # (sb) make a smb.conf.clean we can use for the merge, since an existing
1284 # smb.conf won't get overwritten
1285 cp $RPM_BUILD_ROOT/%{_sysconfdir}/%{name}/smb.conf $RPM_BUILD_ROOT/%{_datadir}/%{name}/smb.conf.clean
1292 new conf file format. The merged data is in smb.conf, with comments like
1294 # *** merged from original smb.conf: ***
1297 smb.conf. A log of what took place should be in:
1299 /var/log/samba/smb-migrate.log
1301 A clean samba3 smb.conf is in /usr/share/samba, named smb.conf.clean.
1302 Your original conf should be /etc/samba/smb.conf.tomerge.
1304 The actual merge script is /usr/share/samba/scripts/smb-migrate.
1315 %_post_service smb%{samba_major}
1333 # since smb config moved from /etc to %{_sysconfdir}/samba
1347 perl -pi -e 's/(\/etc\/)(smb)/\1%{name}\/\2/' %{_sysconfdir}/%{name}/smb.conf
1349 # Fix the logrotate.d file from smb and nmb to smbd and nmbd
1351 perl -pi -e 's/smb /smbd /' %{_sysconfdir}/logrotate.d/samba
1359 # (sb) merge any existing smb.conf with new syntax file
1361 # (sb) save existing smb.conf for merge
1362 echo "Upgrade: copy smb.conf to smb.conf.tomerge for merging..."
1363 cp -f %{_sysconfdir}/%{name}/smb.conf %{_sysconfdir}/%{name}/smb.conf.tomerge
1364 echo "Upgrade: merging previous smb.conf..."
1365 if [ -f %{_datadir}/%{name}/smb.conf.clean ]; then
1366 cp %{_datadir}/%{name}/smb.conf.clean %{_sysconfdir}/%{name}/smb.conf
1368 %{_datadir}/%{name}/scripts/smb-migrate commit
1429 %_preun_service smb%{samba_major}
1433 # /sbin/chkconfig --level 35 smb reset
1473 --slave %{_libdir}/cups/backend/smb cups_smb %{_libdir}/cups/backend/smb%{alternative_major} || \
1498 %attr(-,root,root) %config(noreplace) %{_initrddir}/smb%{samba_major}
1572 %exclude %{_bindir}/smb*m*nt%{samba_major}
1573 %exclude %{_mandir}/man8/smb*m*nt*.8*
1576 /%{_libdir}/cups/backend/smb%{alternative_major}
1592 %attr(-,root,root) %config(noreplace) %{_sysconfdir}/%{name}/smb.conf
1593 %attr(-,root,root) %config(noreplace) %{_sysconfdir}/%{name}/smb-winbind.conf
1597 %{_mandir}/man5/smb.conf*.5*
1601 %attr(0750,root,adm) %{_datadir}/%{name}/scripts/smb-migrate
1602 %attr(-,root,root) %{_datadir}/%{name}/smb.conf.clean
1844 - sync smb.conf with drakwizard (which also fixes quoting of macros which
1855 to diable unix extensions in smbmount (and via 'unix extensions' in smb.conf)
1897 - Don't clobber smb.conf backup for no reason
1901 - Only update smb.conf in upgrade from <3.0.1-3mdk (via trigger) and update
1917 - add migrate script to merge existing smb.conf
1964 - Update configs (fix winbind init script, add example scripts in smb.conf)
1968 - Fix mount.smb{,fs} alternatives (spotted by Laurent Culioli)
2173 Added patch to smb.init from 2.2.2 (got missed with 3.0-alpha1 patches)
2190 - Redid smbmount-sbin patch and smb.conf patch (20), removed xfs quota patch
2197 - fixed %post xxx problem (smb not started in chkconfig --Thanks Viet & B. Kenworthy).
2206 - added "recycle bin = .recycled" parameter in smb.conf [homes].
2222 - Patch for smb.conf to fix incorrect lpq command, typo in winbind,
2252 - Removed patch to smb init.d file (applied in cvs)
2270 - Removed a wrong comment in smb.conf.
2283 - Added smbcacls (missing in %files), modification to smb.conf: ([printers]
2320 - fixed smb.conf a bit, rebuilt on cooker.
2324 Cleaned up smb.conf, and added some useful entries for domain controlling.
2337 - /sbin/mount.smb and /sbin/mount.smbfs now point to the correct location
2353 added _post_ and _preun_ for service smb
2385 Fixed fixinit patch (/etc/samba/smb.conf)
2388 - Now use packaging/Mandrake/smb.conf, removed unused and obsolete
2390 smb.conf to match the spec file. Added configuration for ntlogon to
2391 smb.conf. Removed pam-foo, fixinit and makefilepath patches. Removed
2437 - Changed default print command in /etc/smb.conf, so that the Windows
2450 - Fixed 'guest ok = ok' flag in smb.conf
2453 - Allowed guest account to print in smb.conf
2461 - Changed smb.conf for better CUPS configuration.
2473 - Fixed smb.conf entry for CUPS: "printcap name = lpstat", "lpstats" was
2483 - Added CUPS support to smb.conf
2484 - Added internationalization options to smb.conf [Global]
2534 - made smbmnt and smbumount suid root, and only executable by group 'smb'
2535 add to 'smb' group any user that should be allowed to mount/unmount
2554 - add a mount.smb to make smb mounting a little easier.
2555 - smb filesystems apparently do not work on alpha. Oops.
2614 - Use of chkconfig in place of individual symlinks to /etc/rc.d/init/smb
2616 - Updated smb.init restart mechanism
2618 - Fixed smb.conf file path for log files
2619 - Fixed smb.conf file path for incoming smb print spool directory
2620 - Added a number of options to smb.conf file
2622 - Added smbuser file and smb.conf file updates for username map