History log of /linux-master/arch/x86/include/asm/genapic.h
Revision Date Author Comments
# e2780a68 17-Feb-2009 Ingo Molnar <mingo@elte.hu>

x86, apic: merge genapic.h into apic.h

Impact: cleanup

Reduce the number of include files to worry about.
Also, most of the users of APIC facilities had to
include genapic.h already, which embedded apic.h,
so the distinction was meaningless.

[ include apic.h from genapic.h for compatibility. ]

Signed-off-by: Ingo Molnar <mingo@elte.hu>


# 28aa29ee 17-Feb-2009 Ingo Molnar <mingo@elte.hu>

remove: genapic prepare

Signed-off-by: Ingo Molnar <mingo@elte.hu>


# c1eeb2de 17-Feb-2009 Yinghai Lu <yinghai@kernel.org>

x86: fold apic_ops into genapic

Impact: cleanup

make it simpler, don't need have one extra struct.

v2: fix the sgi_uv build

Signed-off-by: Yinghai Lu <yinghai@kernel.org>
Cc: Andrew Morton <akpm@linux-foundation.org>
Signed-off-by: Ingo Molnar <mingo@elte.hu>


# d53e2f28 28-Jan-2009 Ingo Molnar <mingo@elte.hu>

x86, smp: remove mach_ipi.h

Move mach_ipi.h definitions into genapic.h.

Signed-off-by: Ingo Molnar <mingo@elte.hu>


# 83d7aeab 28-Jan-2009 Suresh Siddha <suresh.b.siddha@intel.com>

x86: remove mach_apic.h, fix

Use apic_read() instead of open-coded mmio.

Signed-off-by: Ingo Molnar <mingo@elte.hu>


# 1dcdd3d1 28-Jan-2009 Ingo Molnar <mingo@elte.hu>

x86: remove mach_apic.h

Spread mach_apic.h definitions into genapic.h. (with some knock-on effects
on smp.h and apic.h.)

Signed-off-by: Ingo Molnar <mingo@elte.hu>


# 0939e4fd 28-Jan-2009 Ingo Molnar <mingo@elte.hu>

x86, smp: eliminate asm/mach-default/mach_wakecpu.h

Spread mach_wakecpu.h's definitions into apic.h and genapic.h
and remove mach_wakecpu.h.

Signed-off-by: Ingo Molnar <mingo@elte.hu>


# 3d5f597e 28-Jan-2009 Ingo Molnar <mingo@elte.hu>

x86, smp: remove ->restore_NMI_vector()

Nothing actually restores the NMI vector - so remove this
logic altogether.

Signed-off-by: Ingo Molnar <mingo@elte.hu>


# abfa584c 28-Jan-2009 Ingo Molnar <mingo@elte.hu>

x86: set ->trampoline_phys_low/high on 64-bit too

64-bit x86 has zero for ->trampoline_phys_low/high, but the smpboot
code can use these values - so it's better to set them up to their
correct values.

Signed-off-by: Ingo Molnar <mingo@elte.hu>


# 5f836405 28-Jan-2009 Ingo Molnar <mingo@elte.hu>

x86, smp: clean up mps_oem_check()

Impact: cleanup

- allow NULL ->mps_oem_check() entries

- clean up the code flow

Signed-off-by: Ingo Molnar <mingo@elte.hu>


# d4c9a9f3 28-Jan-2009 Ingo Molnar <mingo@elte.hu>

x86, apic: unify phys_pkg_id()

- unify the call signature of 64-bit to that of 32-bit

- clean up the types all around

- clean up namespace contamination

Signed-off-by: Ingo Molnar <mingo@elte.hu>


# a27a6210 27-Jan-2009 Ingo Molnar <mingo@elte.hu>

x86: refactor ->check_phys_apicid_present() subarch methods

- spread out the namespace to per driver methods

- extend it to 64-bit as well so that we can use
apic->check_phys_apicid_present() unconditionally

Signed-off-by: Ingo Molnar <mingo@elte.hu>


# a21769a4 27-Jan-2009 Ingo Molnar <mingo@elte.hu>

x86, apic: clean up ->cpu_present_to_apicid()

- separate the namespace

- remove macros

Signed-off-by: Ingo Molnar <mingo@elte.hu>


# 72ce0165 27-Jan-2009 Ingo Molnar <mingo@elte.hu>

x86, apic: clean up ->setup_apic_routing()

- separate the namespace

- remove macros

- remove namespace clash on 64-bit

Signed-off-by: Ingo Molnar <mingo@elte.hu>


# 2e867b17 27-Jan-2009 Ingo Molnar <mingo@elte.hu>

x86, apic: remove no_balance_irq and no_ioapic_check flags

These flags are completely unused. (the in-kernel IRQ balancer has
been removed from the upstream kernel.)

Signed-off-by: Ingo Molnar <mingo@elte.hu>


# bdb1a9b6 27-Jan-2009 Ingo Molnar <mingo@elte.hu>

x86, apic: rename genapic::apic_destination_logical to genapic::dest_logical

This field name was unreasonably long - shorten it.

Signed-off-by: Ingo Molnar <mingo@elte.hu>


# 08125d3e 27-Jan-2009 Ingo Molnar <mingo@elte.hu>

x86: rename ->ESR_DISABLE to ->disable_esr

the ->ESR_DISABLE shouting variant was used to enable the esr_disable
macro wrappers. Those ugly macros are removed now so we can rename
->ESR_DISABLE to ->disable_esr

Signed-off-by: Ingo Molnar <mingo@elte.hu>


# f8987a10 27-Jan-2009 Ingo Molnar <mingo@elte.hu>

x86, genapic: rename int_delivery_mode, et. al.

int_delivery_mode is supposed to mean 'interrupt delivery mode', but
it's quite a misnomer as 'int' we usually think of as an integer type ...

The standard naming for such attributes is 'irq' - so rename the following
fields and macros:

int_delivery_mode => irq_delivery_mode
INT_DELIVERY_MODE => IRQ_DELIVERY_MODE
int_dest_mode => irq_dest_mode
INT_DEST_MODE => IRQ_DEST_MODE

Signed-off-by: Ingo Molnar <mingo@elte.hu>


# 306db03b 27-Jan-2009 Ingo Molnar <mingo@elte.hu>

x86: clean up apic->acpi_madt_oem_check methods

Impact: refactor code

x86 subarchitectures each defined a "acpi_madt_oem_check()" method,
which could be an inline function, or an extern, or a static function,
and which was also the name of a genapic field.

Untangle this namespace spaghetti by setting ->acpi_madt_oem_check()
to NULL on those subarchitectures that have no detection quirks,
and rename the other ones (summit, es7000) that do.

Also change default_acpi_madt_oem_check() to handle NULL entries,
and clean its control flow up as well.

Signed-off-by: Ingo Molnar <mingo@elte.hu>


# 9a6801da 27-Jan-2009 Ingo Molnar <mingo@elte.hu>

x86: remove APIC_INIT / APICFUNC / IPIFUNC

The APIC_INIT() / APICFUNC / IPIFUNC macros were ugly and obfuscated
the true identity of various APIC driver methods.

Now that they are not used anymore, remove them.

Signed-off-by: Ingo Molnar <mingo@elte.hu>


# c8d46cf0 27-Jan-2009 Ingo Molnar <mingo@elte.hu>

x86: rename 'genapic' to 'apic'

Rename genapic-> to apic-> references because in a future chagne we'll
open-code all the indirect calls (instead of obscuring them via macros),
so we want this reference to be as short as possible.

Signed-off-by: Ingo Molnar <mingo@elte.hu>


# 6781d948 27-Jan-2009 Ingo Molnar <mingo@elte.hu>

x86, genapic: provide IPI callbacks unconditionally

64-bit x86 uses the IPI callbacks even on UP - so provide them
generally.

Signed-off-by: Ingo Molnar <mingo@elte.hu>


# 505deeb1 27-Jan-2009 Ingo Molnar <mingo@elte.hu>

x86, genapic: cleanups

Unify genapic.h some more.

Signed-off-by: Ingo Molnar <mingo@elte.hu>


# ced733ec 27-Jan-2009 Ingo Molnar <mingo@elte.hu>

x86, genapic: finish unification

Unify remaining bits of genapic_32/64.h.

Signed-off-by: Ingo Molnar <mingo@elte.hu>


# ef7471b1 27-Jan-2009 Ingo Molnar <mingo@elte.hu>

x86, genapic: unify struct genapic

Move over the (now identical) struct genapic definitions from
genapic_32/64.h to genapic.h.

Signed-off-by: Ingo Molnar <mingo@elte.hu>


# bb898558 17-Aug-2008 Al Viro <viro@zeniv.linux.org.uk>

x86, um: ... and asm-x86 move

Signed-off-by: Al Viro <viro@zeniv.linux.org.uk>
Signed-off-by: H. Peter Anvin <hpa@zytor.com>